3D Frame Packed output

@sam_nazarko Finally bit the bullet and am trying out the 3d test build. Can’t seem to get proper 3D playback (I get what looks like an aborted over/under where the top of the frame is black and the “under” is a squeezed version of the full frame). I started by running the command set in the 4.9 build (added the correct repository and ran both install commands + the reboot). Then I downgraded: sudo apt-get install --reinstall vero3-mediacenter-osmc=18.6.0-13

Did I miss a step somewhere?

It would be most advantageous if you posted some logs which may show where the issue is.

So I had to reason to suspect that the install might have failed, so I’ve just done a clean install of Vero from the June build on the main download page. Then reinstalled 4.9. Then ran the downgrade command again. After the downgrade executes via SSH, my Vero is hanging/staying static on a command line screen ending in “OK} Started update UTMP about System Runlevel changes.”

I’ve left it for a few minutes and it’s just stayed on that. Is that normal? Should I just reboot it via ssh to get back to the GUI?

Will submit logs if I’m still having issues after that, but I just want to understand what I should be seeing here

After downgrading you need to reboot. Kodi won’t restart automatically as our update system doesn’t know if there are other updates to install.

1 Like

So my reinstall didn’t do anything. I go to play any 3d FP MKV and I get some weird version of over under (3D is set to "auto). Here’s the logs.


EDIT: also, after my clean install my Vero remote isn’t responding/working anymore (I’m using a keyboard and mouse to navigate for now). How might I get that working?

Try to set Adjust display refresh rate to On Start/Stop

Just changed it. Sadly no change.

TV supports 3D? Did you try without the AVR between TV and Vero?
Also you have “Playback mode of stereoscopic 3D videos: Ask me” so you get the popup?

Files play perfectly in 3D off of a raspberry pi. I don’t get the pop up. Tried changing to “preferred” instead of ask. No change.

EDIT: also, FWIW, the projector doesn’t switch into 3D mode. However if I switch it from auto to side by side or over under it engages the 3D mode then.

Can you try to rename the files you’re playling from e.g. Avatar (2019) 3D.mkvto Avatar (2019) 3D.MVC.mkv? If that does not help please attach new logs. From the old logs above I can see that 3d resolutions are detected, but Kodi doesn’t even try to detect if the movie is 3D. That’s weird.

For automatic 3d mode detection the mkv should contain a stereo mode tag. This is missing (see 3D Frame Packed output - #160 by mattmarsden) .

You nailed it. It’s the stereo mode tag that’s missing. I tried it with some newer makemkv rips and it works perfectly with .mvc in the file. I’ll just have to add those tags to my older files. thanks!

no problem, you’re welcome!

Any update on the macroblocking problem? Just tried to watch my first 3D movie via a Vero (Avatar). Had to switch to my disc player after five minutes because the macroblocking was just too distracting. I know it was mentioned a while back that it was something that had to be fixed by a microcode update. Is this likely to be addressed at all given the declining use of 3D?

I don’t have an update, but what title is giving you constant issues? We tend to find that it’s periodic rather than constant. Letting us know what title is problematic constantly might give us some more clues.


It wasn’t constant, but the title was Avatar. Noticed macroblocking twice in the first five minutes or so of the movie.

That’s a title with a known issue.

Unfortunately we have no update at this time, but we continue to push it.


how does this macroblocking issue look like?

Macro-blocking is when the picture momentarily loses resolution and breaks up into little squares. With this issue you get a brief “pulse” of macro-blocking; it lasts for maybe 1 second, and happens once every few minutes on affected titles. Only some films are affected, though - “Avatar” and “Gravity” are particularly bad.

I’m seeing a weird issue sometimes where I get a line down the middle of the screen, a split screen effect with 3D, with one side a bit brighter than the other… and 3D effect not as good as my Zidoo X9S and Z9S. This was with a 3D ISO the last time, so don’t know if this happens more with it vs. MVC MKV. Anyone have this?

That’s weird. Can you take a photo when it happens the next time? And please attach some logs. From your description it sounds like it switches into a different 3D mode, or one of the CPU registers got f*cked up. Does it stay like this until you stop the movie?