3D Frame Packed output

It helps a bit, yes. Why do you think it crashed? I can see some problems when trying to access that ISO file. Is that one stored on a harddisk attached to the Vero?

From the logs I can’t see that playback has even started. I’d suggest to test again but just wait a couple of minutes before you pull the plug. I’d like to know if there are some timeouts, because as I said, I can’t see that the playback has started.

I will try that tomorrow. The drive might be underpowered to so I will try to get it some more current aswell and maybe a USB stick if I find one large enough.

I also found this EDID information for this PJ
HDMI:EDID CEA (32) 1920x1080p 24Hz 3D supports: FP|TopBot
HDMI:EDID CEA (4) 1280x720p 60Hz 3D supports: FP|TopBot
HDMI:EDID CEA (5) 1920x1080i 60Hz 3D supports: SbS-HH
HDMI:EDID CEA (19) 1280x720p 50Hz 3D supports: FP|TopBot
HDMI:EDID CEA (20) 1920x1080i 50Hz 3D supports: SbS-HH

Maybe it sheds some light on my probs.

So I powered the harddrive from a second usb socket and tried to start the video. Now I got to chose the type of 3D but then it crashed. So I did what u asked and let the Vero run for a few minutes before pulling the plug after crash. This resulted in this log: https://paste.osmc.tv/eyidexusar

That one was perfect, thanks!

I can see in the logs that the mode initialization fails because the 1080p FP mode can’t be found. So it falls back to the default 2D GUI resolution but Kodi plays the movie in 3D.

You’re still mentioning that it crashes. Why do you think it crashes? What happens if you press “stop” and then wait a minute or so instead of pulling the plug?

@grahamh, can you have a look at this issue? According to @accolon his projector should be capable to display 3D frame packed at 1080p, but the reported modes show only:

2020-10-29 16:50:55.294 T:4069400592  NOTICE: Found 3D resolution 1280 x 1470 with 1280 x 720 @ 50.000000 (FP)
2020-10-29 16:50:55.294 T:4069400592  NOTICE: Found 3D resolution 1280 x 1470 with 1280 x 720 @ 60.000000 (FP)
2020-10-29 16:50:55.294 T:4069400592  NOTICE: Found 3D resolution 1280 x 1470 with 1280 x 720 @ 59.940060 (FP)

Is this an EDID decoding issue? Because @accolon mentioned:

Only 24Hz looks to be 1080p, the rest is 1080i, dunno if that is an issue though.

Well, 1080p24Hz is a mandatory format for 3D but we’re not listing it because 1080p24Hz 2D is not shown as supported. To show 3D support, we put a flag against the entry in the SVD table - but there isn’t one!

The EDID doesn’t contain any 3D modes so we can only assume it supports the mandatory formats and no others. IIRC we had issues with 1080i (supported for SbS) so maybe that’s related.

We would have to add a quirk to the EDID parser to get 1080p24Hz working. Is there a disp_cap_3D file override available?

@sedit1, I hope I’ve fixed that issue. It should be part of the next testbuild.

1 Like

Is this something I can find on my Vero? Sorry for my noobish questions.

1 Like

Sorry, that was a question for @tanio99.

Ok in good hands then! Just tell me if u need me to do anything.

Thank you so much! Really appreciate your effort!

@accolon, create a file called disp_cap_3d in the /home/osmc/.kodi/userdata directory and add these lines to it:

1080p24hz FramePacking TopBottom
1080i50hz SidebySide 
1080i60hz SidebySide 
720p50hz FramePacking TopBottom
720p60hz FramePacking TopBottom

then reboot your Vero and test again. Let us know if anything has changed.

Note: these lines tell Kodi which 3D resolutions are supported. If that file exists it overrides information from EDID. So it might still be the case that your projector can’t show the video because it simply does not support that resolution.

Now it seems to be working! Thx for the help, you are awesome. I will keep you posted if I stumble upon other problems.

1 Like

A post was split to a new topic: Plex add-on not saving login

My apologies. I know this is from weeks ago, but I don’t think I replied to this.

Not exactly sure what you mean by the ".MVC filename tag". Some of my files are named as “MovieName (YEAR) - 3D-MVC” but since this post started I am seeing the same behavior on 2D movies with the Vero that I don’t see in OSMC on the Pi3. I guess I just never tried those until more recently.

Yes. Did that the second a working test build was released as per instructions from the Wiki.

I can’t answer that. Since the PfK add-on works fine in OSMC on the Pi3 as well as LibreELEC it seems to be something unique to the Vero4K+ build, but that of course does not mean it can’t be something buggy about the PfK that the Vero is just pickier about than those other builds.

Sorry to ask this:
Is there a way to quickly change the audio track from remore control in Vero 4K+?
Thank you for help.

If you long-press the menu key, that gets you into the Audio menu. It’s not too many more clicks from there.

Thank you for quick help. :smiley: :smiley: :smiley:

1 Like

On my Vero 4K (not the +) I have the volume down button mapped to toggle Audio Passthrough on /off and the volume up button to toggle Subs on/off. @darwindesign showed me how to do it. In case you are interested, here is the thread. darwindesign may help you do other things with your keys.
[mod edit]

Are you using the Vero to control your volume? I use my AVR so this is foreign to me. Do you have surround sound? If so how do you use it? ARC?