Cannot download any artwork from tmdb

Hi,

Cannot download any artwork from tmdb from my Vero 4K+

In log, I am getting errors like:

2020-10-15 10:47:33.131 T:3931103968 ERROR: CCurlFile::Stat - Failed: Failure when receiving data from the peer(56) for http://image.tmdb.org/t/p/original/tLCDKsXo6D84IVFanoElosSEKdp.jpg

Running manually

curl -O http://image.tmdb.org/t/p/original/tLCDKsXo6D84IVFanoElosSEKdp.jpg

works fine, I get the image.

Tmdb add-on is up-to-date. Running June update.

Any ideas?

Thanks

This is has already been reported on the Kodi forum.

FYI

The issue is not affecting all platforms,

For me, doing the same thing from a windows 10 PC,

does not produce any error. However, It does not work in OSMC.

Latest comments on kodi forum suggest that is related to http2

https://forum.kodi.tv/showthread.php?tid=357709&pid=2981987#pid2981987

Thing is, that if tmdb changed something at the servers permanently,

we will need a workaround (or a patch) for the OSMC platform.

Definitely is NOT region related

I am monitoring this.

same thing has just started with my vero 4K+

common.themoviedb.org scraper version 3.2.5 updated by Team Kodi Member @olympia Looks like it fixes the artwork download problem.
I download the zip file from here – https://mirrors.kodi.tv/addons/krypton/metadata.common.themoviedb.org/ and installed it. So far so good.

i installed the updated scraper and all seems to be working good again. Thank you for the updated link

Hi,

So I just posted a new thread which is basically this issue. There is already a workaround for this on Matrix and another PR was created (which worked for me ) in kodi to fix this… Hopefully we can backport this to OSMC

Just an FYI that the scraper updates will address any new media you scrape, but existing media will still have references to http instead of https. So if you go to change the art on stuff you’ve scraped previously, there might still be issues. While the Kodi team works on a more global fix, refreshing the scrape should get you new art with https references.

2 Likes

Seems that the movie database is now at 5.2.2 incl the movie database scraper library 3.2.6 as mentioned https://forum.kodi.tv/showthread.php?tid=357709

For me this worked (after updating all the addons) with a yesterday added movie which was not detected in scraper

Hi
I was reading on github https://github.com/xbmc/xbmc/issues/18572 that this issue is the same that has made PVR IPTV Simple Client useless. Does anyone know anything about that?

Reading the GitHub comments you linked it should be possible to fix your problem by editing the m3u file or installing a alpha version of kodi where you have a toggle to disable http2

It did not work editing my m3u, and I don’t know how to bring my vero4k+ up to Kodi 19. Can it be done?

The latest nightly is quite old now but a fresh one should be available soon

You don’t need Kodi 19 to fix your issue, it should be fixed in the upcoming OSMC update

Of course, I just wanted to see the games today.
When can we expect the next OSMC update?

It’s available now.

2 Likes