Certain files won't buffer (or much)

Some video files don’t seem to buffer (much), and just get stuck. In two cases, they’re 720p or 1080p .mp4 files I made in iMovie. The latter is a 15m video that’s about 3GB. It gets completely stuck and won’t buffer at all. (I can play the version I put on YouTube just fine). Another one is a 20 min TV episode in .mkv format (700MB). It buffered a min or les, even on pause.

Vero 4K+ is on an ethernet connection and iperf3 ranges widely between 33-88Mbits/sec ATM. Mounts are NFS.

I have video on several HDD volumes connected to Mac Pro, but have had problems on at least 2 of those volumes.

Kodi/Vero updated to current (Nov 2019 I think).


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


The relevant log should be the OLD log. [turned on debug loggging>reboot (exit)>play each file (reproducing problem>turn off debug logging>reboot (exit)]


personal video (imovie):
Disneyland NYE 2020.mp4



As a fist step I would try with

GUI Settings->Player->Video

There activateAdjust Display Refresh Rate” for Start/Stop

Thanks. Tried that, but didn’t work. Seemed to slightly change the point at which videos are getting stuck, tho.

While quite unlike that it is a network issue I still would suggest to try to copy the file to the emmc and play from there as the next test.

Thanks for your help. Will do that later and report back. In the meantime, if you or anyone can peek at the (old) log, I’d appreciate it. I can’t really spot where the problem is even. Maybe an add-on, I was thinking?

You have an add-on that is connecting to google and onedrive. Try disabling that.

Thanks for the help so far everyone. Unfortunately disabling the Guzman add-ons did not help. Playing the problem files locally from the SD card did help. (Both play fine locally.)

However, it’s still hard to believe it’s a network problem, as iperf3 tested ok and also because other files of similar sizes on the same attatched volumes play fine.

I wouldn’t worry about it if it were just these 2 files, but it seems that I have the same problem with most files created in iMovie and with an entire season of the TV show in question.

Is there a way to force a bigger buffer?

I’m not convinced that this is the case. From your first post:

Any wired network that “ranges widely between 33-88Mbits/sec” is having performance issues. It should be a pretty constant 93-94 Mbps, even if the other end of the cable is only providing 100Mbps…

That won’t help to fix a problematic network and is already quite large on the Vero4K+. Could you please:

  1. Show us iperf3 figures both ways (ie with the -R option, as well), between your Vero4K+ and file server.
  2. Describe your file server and network set-up.
1 Like

OK… Yeah, then it’s really F’d up. Worse now than last time I tried. No idea why (see below).

Here’s with my Mac (.202) as server:

And Here’s with the Vero (.234) as server:

Serving: via NFS from MacPro 2009 (upgraded hardware) running MacOS 10.14.6. Several attached media drives connected via USB3.0 hub.

Network: Mac (home office, 2nd floor) > ~6’ ethernet cable > Cat10 jack > long ethernet wiring to basement router (professionally installed) > new ASUS AX88U wired/wireless router > ~10 ft ethernet cable > Vero 4K+.

(because server is 2 floors up and Mac is desktop tower and Vero displays on 50" LCD, no way to bring them physically together)

Those iperf3 figures are simply terrible.

It’s a bit ambiguous but do you mean that the cable was “professionally installed”? That would probably be the first thing I’d test. Remove the long cable from the picture by temporarily moving the Vero4K+ next to the Mac and connect them together either with the ASUS router or via a cheapo unmanaged switch. See if the iperf3 figures are more sensible.

Often it’s a dodgy connection on the wall socket.

by professionally installed I mean by an electrician. I’ll see what I can test later and report back. I do not really think the problem lies in the long cable or the socket, because I get plenty high and consistent speeds from the cable modem > router > and all the way up via that long cable & socket > Mac. (Right now testing a download @ 23 MB/s). I will try to find another device to run iperf3 on with the same connections currently attached to the Vero.

(also, while the evidence is certainly great that the network is f’d, I still find it puzzling that some files of similar sizes on the same physical volumes play fine over the same connections.)

Interesting test results here. I simply switched the ethernet cables on the Vero & the AppleTV. (each ~10ft direclty to router). Now the Vero is getting a consistent >230 Mbps to and from Mac:


I would have expected then that the cable that was connected to Vero and now is connected to AppleTV was faulty. However, no noticable lags on AppleTV (tested Amazon, Netflix). Network Speet Test (ookla) app shows 90+Mbps down, 11 Mbps up. I tried a different cable to ATV with same results. Acceptable figures, though Mac is getting 236 Mbps down & 11Mbps up (running ookla in Safari). [BTW: don’t suppose there’s any app to run iperf3 on a non-jailbroken ATV4?]

AppleTV getting less than half of Mac, but still plenty for video streaming, while Vero with same cable got sh*t? Hard to explain, but for now seems OK…

However, now my key repeat woes are back!

Well, 230 Mbps isn’t exactly stellar performance but it’ll be enough to stream your movies. Unfortunately, the figures that count, the reverse traffic, show worse performance, with one of the reverse figures showing zero bytes for a second.

[ 4] 8.00-9.00 sec 0.00 Bytes 0.00 bits/sec

It’s now better than a 100 Mbit connection but is still badly underperforming for a gigabit network. Some further quick checks you can try: further replace cables one at a time; try different ports on the router; and reboot the router.

1 Like

OK. This continues to be a big problem. Had time to troubleshoot extensively.

Summary: I am 99% sure the problem is in the Vero 4K+ ethernet interface.

Details: I turned the wifi interface on the Vero under myOSMC completely, running only internet. I tested several different physical routes and different cables, all with similar results. Finally, I installed iperf3 on a 10 year old laptop (running macOS 10.12.x). Used the exact same physical route to the laptop as last used to Vero. Now getting perfect results.

See this iperf3 server results. Media serving Mac ( running in -s mode. Vero = (ethernet interface). MacBook wifi = MacBook ethernet =


There was an ethernet issue with some early versions of the Vero4K+, though that was quite some time ago.

Do you remember when you bought your device?

Yes indeed, it was one of the first 4K+ units to ship. I reported problems to Sam at the time, but thought it was software. I just wrote him an email.

Then it might well be a hardware fault.
cc @sam_nazarko

I’ll follow up on your email shortly.


1 Like