Dependency failed for Local File Systems after December update

Hi everyone. Unfortunately there was no notification on the FB page, otherwise I would not let my OSMC update itself. Anyway, after getting stuck on blue OSMC boot screen I also don’t get network. No keyboard to try anything else. I have tried the suggested solution, to grab the mmc-overlay.dtb and placed it in first attempt to /boot/overlays and have changed the /boot/config.txt and added dtoverlay=mmc. After that change, it boots but it has a "A start job is running for dev-sda1.device (counter from 0 / 1min 30s) and after 1.5 min it goes to shell and recovery mode. On my second attempt I have after reading everything on this page again, tried to place the mmc-overlay.dtb file under /boot/dtb-4.3.3-2-osmc/overlays directory and rebooting but again it’s the same. Countdown and recovery shell. I have also tried typing systemctl default there, and got “Hangup” message and nothing. I thought I mistyped so again systemctl default and then it got stuck.

Can someone please suggest what else should I do to get this going?

Also, my config.txt is:

and my card is Transcend 16GB with really small small letters on the back: 9181AA 16G 07DS2


Many thanks!

When did you update? As @DBMandrake wrote in his post if you updated after the 29th the overlay was already included and just adding dtoverlay=mmc would solve the issue.

Are you having a USB install?

Provide logs if you can access the recovery console

I updated exactly 24 hours ago. As you can see in my config.txt, I have added dtoverlay=mmc but unfortunately it does not resolve the problem.

No, I’m running it from an SD card. I do have usb drive but it contains only personal data. Also some of the config files are sitting there (for flexget and transmission).

Logs are here:

In the mean time, since it’s New Year’s Eve, I quickly wanted to have a fresh installation so we can see a movie or something (I made a backup copy of the sdcard with dd) so I grabbed a fresh image and this one has a different errror, it just sits at “waiting for the root filesystem” or something like that. I have even tried again with the installer but still the same. So does this mean the original image is broken? Why don’t you remove it or warn people if it’s not working?

I did a reinstall this afternoon, it’s all running fine… so no problem with the image!

I only used one command “dd if=OSMC_TGT_rbp2_20151129.img of=/dev/sdc” waited until finished and plugged in to my raspberry pi 2. Sdc is my sdcard. And it does not boot. It says it’s waiting for root partition or filesystem. So what am I doing wrong exactly?

Can you take a quick photo for me?

Have a good New Year!



Thank you! To you too!

Because the image is not broken.

There is a compatibility issue with a very small percentage of SD cards with the new sdhost driver in the December update which is being investigated, however this is not the problem you’re having. You have dtoverlay=mmc in config.txt and I can confirm from your system journal that sdhost is not being used therefore your issue is nothing to do with the sdhost issue reported in this thread.

What I do see however in your log is this:

Dec 30 19:06:41 osmc systemd[1]: Job dev-sda1.device/start timed out.
Dec 30 19:06:41 osmc systemd[1]: Timed out waiting for device dev-sda1.device.
Dec 30 19:06:41 osmc systemd[1]: Dependency failed for /media/usb_hd.
Dec 30 19:06:41 osmc systemd[1]: Dependency failed for Local File Systems.

OSMC is unable to mount your external USB drive, and because you do not have the ‘nofail’ mount option in fstab for the external drive, this prevents the entire system from booting.

You can fix this by adding ‘recovery’ to your /boot/cmdline.txt which will let you boot to an emergency recovery console, then edit /etc/fstab and add the nofail mount option for that drive, then remove ‘recovery’ from cmdline.txt and reboot and you should find you can now boot.

Then you can investigate the problem with your external drive.

The December image (with SDHost), has not been published.

@dcabro: I’ve moved your posts to a new thread as the issue you’re experiencing is not related to the sdhost driver compatibility issue and I want to keep that original thread as on topic as possible.

Issue with the “waiting for root filesystem” was probably related to my sdcard dying. It does not accept writes anymore so I’m no longer able to test anything. Not sure this death of the card is related to the previous problem with the driver or it just reached its number of cycles. For the reference, I’ve been using it for 1.5 year non-stop (my pi is up 24/7). I have reverted to usb install and now everything seems to be working fine.

Thanks guys.