Fast forward/Rewind Issue with amcodec enabled

I’ve been meaning to post this issue for ages. Most of my media files are bog standard MKV files with a 720p h264 video and stereo AAC audio.

I’ve experienced for a while that if you fast forward or rewind “slowly” i.e. x2 or x4 then all works well and playback resumes ok.
However, if you crank up with fast forward speed above this then the “speeded up” playback no longer wizzes through the video and the frame is effectively paused while the progress bar increments along the bottom of the screen. All seems well until you hit play again and the video freezes at this point. You can click stop and then resume playback from that point without issue.

HOWEVER, if you disable the amcodec hardware acceleration then the fast forward/rewind functionality works fine at all speeds and playback resumes ok.

HOWEVER, I find that the video playback feels jerkier with amcodec disabled.

SO, I either need smooth video playback with amcodec disabled OR FF/RW working at all speeds with amcodec enabled.

Any ideas? Thanks in advance.


There has been for sometime a known issue with fast forward & rewind, with kodi in general. The best advise is to use skip steps instead:

Thanks Tom.

1 Like

It has been discussed on the forum a lot that fast forward and rewind are something that is there, but requires massive buffering, depending on the bitrate of a file, of course… So, it will mostly not work properly.

As advised by @Tom_Doyle, skipping forward and backwards is the way to go :slightly_smiling_face:

Thanks for the update. So, I’m far from the only one. Interesting that the behaviour is improved with amcodec disabled. Maybe I’ll bite the bullet and give Kodi v18 a go!!!

You’re not the first one to ask about this, yes. But even the new OSMC remote doesn’t have fast forward and rewind buttons anymore, so it’s kind of official that these buttons are somewhat not used anymore. I doubt that there will be much interest in bringing them back functioning like one would expect from local media players like VHS or DVD/Blu-ray players (for the latter it’s a lot easier to do the buffering locally directly from the disc, not via a limited network setup that most use with a Vero 4k).

Skipping is arguably a lot more precise and easier to implement. So, even in Kodi 18, I’d expect this not to change a lot… Best try skipping and see whether this does the job for you, too. :wink:

I have noticed that it works best with high compressing codecs.
Same movie using x264 works bad, while using HEVC works nicely :slight_smile: Smooth :slight_smile: