HDMI-CEC seems to stop working after a couple of hours

If your entire device is crashing, it is not a CEC issue.

Since it crashed again (no sound from soundbar, tv complaining that there is problem with hdmi eARC, no picture on HDMI connected to Vero 4k+) I tried SSH-ing to Vero and it works.

I stopped OSMC with:
sudo systemctl stop mediacenter (the picture on tv switched from no signal to black screen)
and then:
sudo systemctl start mediacenter, (the picture on tv switched from black to normal OSMC screen)

and now everything is working again, OSMC is running fine, I can control it with TVs remote and again I have sound from soundbar on eARC HDMI

So a simple stop and restart from SSH brings back the functionality. I am running the test version from USB stick:

Kodi (20.1). Platform: Linux ARM 32-bit (version for Vero)
Release Kodi x32
Kodi compiled 2023-06-03 by GCC 10.2.1 for Linux ARM 32-bit version 5.10.106 (330346)

https://paste.osmc.tv/xijomoyope

Were you able to replicate the problem?

No - but I implemented a number of changes in July and things stayed stable. I’m only doing a relatively small uptime of two weeks, but not seeing an issue presently.

Do I need to keep it up for longer than that?

In my case things break after max 2-3 days of uptime, usually after at least 1 day of no activity (TV turned off). This happens frequently as I need to reboot the Vero 4k+ a lot.

I’m seeing various failures like:

  • TV remote stops working for the Vero 4k+
  • TV remote and soundbar stop working
  • Like the poster above, no image when I turn on the TV. The Vero 4k+ is running fine and I can SSH into it and reboot it gracefully, or command a reboot from the phone app.

I usually don’t have time to troubleshoot as mostly the kids use the TV and this is when the they are waiting to watch their favorite cartoon shows before bed.

To recover, I’ve been doing one or more of the following (from easy to progressively harder):

  • Reboot the Vero 4k+, check if remote works
  • Change HDMI source away and back, check if remote works
  • Power down the Vero 4k+, power it back up, change source away and back, check if remote works
  • Power down everything, power up the TV/soundbar first, and Vero 4k+ afterwards. This has always worked, but it’s a PITA.

Honestly, at this point I’m looking for alternatives to the Vero 4k+ as it is unreliable.

I am testing on Vero 4K + and V and cannot reproduce.

But I will investigate further.

Furthermore, there are posters here that will soon receive Vero V and their feedback will be useful.

20 days since last crash. Should I ditch the test image running on pen drive and switch to official update?

That’d be a good idea

Sam

Are you seeing these crashes even when running the workaround from USB, as posted by Sam?

After seeing a one or two positive posts about this I thought I’d upgrade from the March 2022 release to try for myself. I’m now on the standard bullseye release from July 2023 I believe, not a test build.

Unfortunately it’s still exactly the same in terms of broken CEC and HDMI switching that appears after a time…

All perfectly fine initially but within a few hours of switching the TV to watch another input, the Vero was subsequently not selectable again from the TV menu when I wanted to return to it. (A reminder: my Vero is connected via a Denon AVR into a Sony TV).

Whilst in this state I can still select the Vero via my AVR inputs fine, and it switches to it but there is no CEC control (which was working fine after initial boot/mediacenter service start). I managed to play something (using the Android Kore app to remote control which was already setup) and audio was fine (in previous builds after March '22 this might also have been broken. This is not to say it might not be still, I’ve only done v. Limited testing and in previous builds the symptoms were wide and varied and not always reproducible exactly the same each time.

Restarting mediacenter over SSH (or rebooting/powercycling the Vero entirely) solves it (for now) just as before.

I have just now, in an attempted workaround, noticed the new option to change the CEC client type and so I have changed it to “Playback” from the default “Recorder” just to see what happens next.

I now have 3x “Playback” devices connected via the AVR (a BD Player, a Chromecast with Google TV, and the Vero which has assumed the 2nd device slot, all alongside a single “Tuner” type device (a Manhattan PVR). There are also a few other HDMI devices connected via the AVR: a PC, a Wii U and a Switch.

If this CEC client type change doesn’t prove fruitful, I will probably go back to March 2022 again soon until this is resolved or unless there is something else specific I can try?

It’s probably worth trying the test build posted here. After all, the July build you’ve installed doesn’t actually contain any fixes for this issue.

Sure I might well do - I had maybe incorrectly assumed from ptodic’s message and Sam’s subsequent reply that perhaps the changes in the test build had already been merged into the live repos/official update…

The CEC client type change didn’t make a jot of difference by the way, the input had once again disappeared from my TV this morning…

Glad to have caught this thread! I have the same issue with an LG C8 Oled. Vero+ blocks the CEC after a while. Almost bought a new receiver and brought my TV for repair. The thing that works is to take off Vero+ from the power and turn it back on.

Here’s my HDMI-CEC settings etc, I have my Vero 4k+ connected to a Yamaha RX-A2A AVR and then to a LG OLED48CX6LB TV. I’m not seeing any of the CEC problems described here with this setup. Perhaps this might help ?




and the Yammy RX-A2A HDMI settings (with Standby Through and Sync ON)

1 Like

Unfortunately the CEC just crashed today after 21 days of working fine. I didnt have a chance to switch to normal version. OSMC screen was visible but couldnt control it with tv remote (cec).

After a “sudo systemctl stop mediacenter” and “sudo systemctl start mediacenter” all is back to normal.

Still running the test version from usb.

Shame. Don’t think I’ll even bother with the test image then on this occasion…back to the March 2022 release for me…

Is this fixed in the production/main repos now?

I see a note on the August release notes mentioning fixed CEC issues. Is what’s being described in this thread one and the same? No time to try/test an upgrade from March 22 yet but if someone else confirms it’s all hunky dory I’ll certainly try to make time…

Well, I made the update a few days ago (hoping that the Bug with HDMI-CEC is fixed as Changelog says).
Unfortunately I have to answer you, the bug still persists, HDMI-CEC still stops working after a few days.

Ouch. What were the specific fixes relating to CEC referred to - maybe not this? @sam_nazarko ?

Has anyone else got feedback relating to these problems that have been longstanding since everything that came after the March '22 release?

This thread has had loads of replies/views and there are a few others with similar CEC-related issues: 4k+ CEC EARC issue - #75 by p00chie and Vero 4K HDMI CEC stopped working and Another Vero 4k+ CEC issue - there were seemingly plenty of other people affected…

I would love to help test/fix this (and I did spend time in earlier attempts previously which sadly didn’t prove fruitful) but as my Vero system is used by family (and me) regularly and I have little time to “fiddle”, I need something that “just works” and I only get that on March '22 at the moment - anything that came after has had probs.

It wouldn’t be too much of an issue if it just affected the Vero but last time I tested it doesn’t - it can upset the whole CEC chain in my setup, meaning other devices connected through my AVR sometimes can’t even be selected properly from the TV input menu after the Vero has gone into this state, seemingly hijacking it for everything else…

Still a random completely erratic issue for my relatively simple earc LG TV to LG Soundbar setup. Causes other devices and LG magic remote to not work.