[HOW-TO] Install Plex Media Server Raspberry Pi


We’re going to use the dev2day repo for this, it’s pretty straightforward.

First lets update the package manager
sudo apt update

Next, taken directly from dev2day

This will be in 2 parts, 32-bit OR 64-bit, pick one depending on your architecture;

32-bit ONLY Start

Become root
sudo -i

Add the public key
wget -O - https://dev2day.de/pms/dev2day-pms.gpg.key | apt-key add -

Add th PMS repo
echo "deb https://dev2day.de/pms/$(lsb_release -cs) main" | sudo tee /etc/apt/sources.list.d/pms.list

Activate https
apt-get install apt-transport-https

Update the repos
apt update

install PMS
apt-get install plexmediaserver-installer

32-Bit ONLY End

64-Bit ONLY Start

Become root
sudo -i

Add the public key
wget -O - https://dev2day.de/pms/dev2day-pms.gpg.key | apt-key add -

Add the PMS repo
echo "deb [arch=armhf] https://dev2day.de/pms/$(lsb_release -cs) main" | sudo tee /etc/apt/sources.list.d/pms.list

Activate https
apt-get install apt-transport-https

Enable armhf support
dpkg --add-architecture armhf

Update the repos
apt-get update

install PMS
apt-get install plexmediaserver-installer:armhf

64-Bit ONLY End

Do the following for Both 32-bit & 64-bit

Set Permissions with your text editor (I am using vim but you can use nano etc.)
vim /etc/default/plexmediaserver.prev

Change the user from the default plex to osmc
Save & Exit

Restart the service
systemctl restart plexmediaserver

Exit root

Finally navigate the the IP address of your OSMC in a browser followed by :32400/manage/ e.g.

Am I running OSMC 32 bit or 64 bit?
I am not able to plex server on osmc what should i do
[HowTo] Install Plex Media Server and Add-on on Rasbperry Pi


Does this work on all the devices supported by osmc?

Thanks Tom.


I have only tested on the Raspberry Pi 3



Thanks for updating the title.

Regards Tom.


Should the


Sorry, should be osmc…brain fart on my behalf. Changed the post


While the command is perfectly fine when you know your release codename for sure, I’d rather advise you to use this:
echo "deb https://dev2day.de/pms/ $(lsb_release -cs) main" | sudo tee /etc/apt/sources.list.d/pms.list

On Debian-like distributions that’ll automagically fill in the the release codename.
Sure, if the version does not exist on the repository, it’ll throw an 404 on apt update and the repo will be ignored. But IMHO that’s better than (worst case) installing incompatible dependencies.

The repo contains only binaries for armhf. So it’ll run on the Raspberry 2 and 3.
As for the Vero and Apple TV: I don’t know what CPU powers those devices, nor what instruction set (a.k.a architecture) they use.

I’m sure @sam_nazarko can shed some light into that.

1 Like

How to update plex ? Thanks


First, let me say THANK YOU @eekfonky for the useful guides.
They’ve helped me not only get (almost) everything I want running on my Pi, but be much more comfortable issuing commands. Thank you. I would imagine your guides have saved countless man-hours (and headaches) for people like me.

Second, I have a question.
Dev2Day.de lists two instructions for setting up their Repo and installing Plex Media Server. Your guide seems to follow the first, which is based on ARMv7/RPi2, while the second is for ARM64 which is what the RPi3 is.
Is there any significant difference using the different steps?
As far as I can tell from a previous install your steps work just fine on the RPi3, but the ARM64 steps also seem to work fine.


I’m glad the guides helped. It took me many man hours to figure things out so I thought I’d pay it forward.

As for your question, I’ve honestly not tried the different versions. I’m not a specialist in hardware. If the architecture was wrong you’d probably know pretty quickly as it is unlikely it would work.

I’ll give it a whirl tomorrow and get back to you

1 Like

It all seems fine to me, I’ve updated the how to accordingly

1 Like

This gives me an error (-bash: lsb_release: command not found). Can anyone help? Tnx


There’s a space that shouldn’t be there. Try this;

echo “deb [arch=armhf] https://dev2day.de/pms/$(lsb_release -cs) main” | sudo tee /etc/apt/sources.list.d/pms.list


Thanks - that worked. Plex server is now running on my Pi3 with OSMC.


Forgive my ignorance I’m new to plex but how does it work with osmc installed. Will Plex see my movie library that I’ve already added to osmc or do I have to add them to Plex manually?

Thanks for this looking to try the Plex vr app with my oculus go.


How do I uninstal this? just apt-get remove?
I want to try this oit but it may not work for me



What is the file path for the PMS folder?


Installed PlexServer as suggested in this thread. Worked 5 min and after trying to create a folder on nfs share, it stopped working, Cannot connect.
Message in the browser

This site can’t be reached refused to connect.

Kodi and other stuff work.

BTW. Where are the Plex server logs, |The message on screen was to get them via http, but of course can’t connect anymore.


doesn’t work
who can halp me?


This took a lot of digging… but, in order for Plex Server to actually be able to collect and scan the directory, I had to input the following:

sudo addgroup plex osmc

sudo addgroup osmc plex

Note… I did it after the reboot in the information above.

Downsides to install Plex server in OSMC with Kodi?