[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC

On second examination, it appears that all add-ons installed on my machine are missing. What should I do?

Check for updates again. There was an update earlier today on the staging channel that could cause these symptoms, but not on the release repo.

Sam

Thanks! Updating helped.

Good news: My add-ons are back and RetroPie is showing up in Programs.

Bad news: Retropie doesn’t appear to launch. Instead, kodi just appears to relaunch.

Can’t help with that – I don’t think it’s something that would have changed in the update, but I suspect logs will help.

Logs directly after trying to launch RetroPie from the launcher:
http://paste.osmc.io/ogusucozoh

Aug 28 15:54:19 osmc-Phoebe sudo[886]: pam_unix(sudo:session): session opened for user root by (uid=0)
Aug 28 15:54:19 osmc-Phoebe mediacenter[775]: chown: cannot access '/usr/bin/emulationstation': No such file or directory
Aug 28 15:54:19 osmc-Phoebe sudo[886]: pam_unix(sudo:session): session closed for user root
Aug 28 15:54:19 osmc-Phoebe mediacenter[775]: /home/osmc/RetroPie/scripts/retropie.sh: 20: /home/osmc/RetroPie/scripts/retropie.sh: cannot create /usr/bin/emulationstation: Permission denied

This is definately not right…
Are you sure, that the installer ran fully? Did you do the quick setup from retropie-setup script?

I didn’t see a button called “quick setup.” I did “basic install.” Is that the same thing?

Edit: Retrying basic install. It seems to be doing new stuff, so maybe I did it wrong the first time.
Could not install package(s): fbi omxplayer

Success! Retropie booted!

Great.
Manage Packages >> Quick Install
Should do the trick.

There is no Quick Install option under Manage Packages. Am I doing something wrong?

This is also what I saw. I did get it working by doing “basic install” in the previous menu. SNES emulation isn’t working, but that’s a known bug.
Edit: Also sound is super buggy or non-existent for me. I haven’t yet looked for solutions to that. I’m on an RPi3.

This seems to change quite often…

Basic install should be right.

Changed that in the first post.

HI all,

@space_escalator, I have the same problem. Tried to boot Retropie after installation, but it only got me back to the OSMC (kodi) screen. I’ll try to restart the installation again, hopefully it will work on my RPi3!

I just did the install on a fresh OSMC on Sunday. Once you run the script from the first post, you need to reboot then run it again. I didn’t get the retropie setup menu after the retrosmc menu on the first run.

On the second run, when you do get the retropie menu, select basic install. Both of these installation processes will take some time. On a RPi 3, I let both run overnight. The retropie script failed on omxplayer (I think) but the thread says it’s not important. Everything runs fine without it so far.

Something is very wrong with Alsa. Sometimes I get sound in the menu, sometimes I don’t. If I do, it’s very delayed. Earlier today, in the RetroPie menu, the sound wasn’t on then came on suddenly. Until tonight, when a friend and I had been playing Super Mario Bros 3 for several hours, there had never been sound in-game. When it suddenly came on, it was choppy and made the game slow down to unplayability.

When I launch any of the RetroPie utilities, I get a stream of Alsa overrun errors before it launches. When I try to change the volume in RetroPie from the start menu, it doesn’t take. (After going back into the menu the volume is back at 0%.)

I did a full update today via the install script.

Also, my Raspberry Pi 3 seemed to be running awfully hot for running NES games. Is that normal, when this device is capable of N64 emulation?

All your problems were discussed before.
Please search this thread.

Edit:
Your sound problems could be related to pulseaudio.
Remove it!

NES seems to need more resources than N64:
This is NOT how emulation works. Also it is not true :wink:
Emulation is always a compromise of accurency and speed.
Very accurate nes emulators can need more resources than a fast, but glitchy N64 emulator.
Try a different emulator for nes if you don’t like the normal one.

Alsa buffer overruns:
Not an error and normal. Especially with emulators.

Thank you so much! Removing pulseaudio fixed all the problems, including the overheating and some lag in the OSMC menus that I thought were just normal! Sorry I didn’t do a very good job searching the thread.

I just came across the same situation. I compiled and installed the ds4drv, set permissions, added udev rules, changed the colour of the led, and added the ds4drv.conf to /home/osmc/.config. Configured the buttons through the menu screen in RetroPie, browsed through RetroPie using the controller, selected a game using the controller… but then the little message at the bottom left saying the wireless controller wasn’t configured. Where else does the controller need to be configured? I already have it configured while connected using a usb cable, but it’s not automatically configuring it with the same config file like I read it’s supposed to when already paired. I noticed that even though it’s paired in OSMC, I can’t actually use it in OSMC.

There’s a version of LibreELEC with emulationstation and retroarch built in, with the ds4drv already installed and configured. The config file is the same, and the only difference I can see, is the developer added the ds4drv as a daemon…

~/system.d/ds4drv.service

[code][Unit]
Description=ds4drv daemon
Requires=bluetooth.service
After=bluetooth.service

[Service]
ExecStart=/usr/bin/ds4drv
Restart=on-success

[Install]
WantedBy=bluetooth.target[/code]

I don’t see that being a difference though. There must be another file somewhere to be configured. I even tried putting the ds4drv.conf in /etc, as the guide said the ds4drv looks for either ~/.config/ds4drv.conf or /etc/ds4drv.conf. Didn’t make a difference. Blah.

Hi mcobit, i thought i’d post my workaround for people having audio issues when bluetooth audio streaming is enabled. As @kiryl pointed out in his post (#586) seems like somethings not playing nice with pulseaudio. Following up on his idea to kill pulseaudio, here’s the workaround that works for me. I did not test this very thoroughly but my NES and SNES games have audio.

Unfortunately, it needs me open an SSH session every time i want to play a retro game.

1-Kill pulseaudio with:

sudo killall -9 pulseaudio

2-make sure it doesn’t respawn while playing RetroPi, do to so, add the following line to
$HOME/.config/pulse/client.conf :

autospawn = no

3- Play your game

4- Once done playing, just to be safe, re-enable the autospawn in
$HOME/.config/pulse/client.conf :
(I’m leaving this to “no” as I’m not using pulse for anything else on my pi)

autospawn = yes

5-restart pulseaudio (seems that it needs to run in system mode for bluetooth audio to work again)

sudo pulseaudio -D --system

Like i’ve mentionned, this is just an ugly workaround but it works for me

Hope this helps.

Playing around with the ds4drv driver again, and although I got it to emulate as an xbox controller, it’s still not configured when a game starts.

/etc/rc.local

/usr/local/bin/ds4drv --hidraw --emulate-xboxdrv --led 000008 &

It even says ‘xbox gamepad’ when using the initial config screen, but just like the ps4 controller, it only works in emulationstudio itself, and not in retroarch (games). It would seem some file is overriding another file once the emulator starts.

Thanks a lot. I might add that for people havin pulse audio installed until a proper fix is found.
I can do it automatically at es startup.