Intermittently “no signal” on TV when switching to Vero 4k+ on Kodi v19.1

First things first, while my vero 4k+ is on, it still runs fine as it did since the first time back in 2018.

But since updating kodi to v19.1, I have noticed than sometimes in the morning when I switch to vero hdmi input on my TV it gives me the “no signal” sign: kodi won’t respond via GUI, but I can ssh, web-browse to its ip, use kore etc. I have to reboot or turn the power off and on again (by the power cord) to resolve the problem.

It is intermittent: It may happen in 1 day or 10 days, there is no pattern. Before that I had up-times up to 40-50 days (eg. till a power failure to the neighborhood).

I have also found this thread: Display turns off (TV says "no signal") Vero 4k+ Kodi v19

But in my case the mentioned setting (Settings → System → Input → Peripherals → CEC Adapter → When TV is switched off → ) is set to “Ignore”.

I will try to provide logs when it occurs again. Anything else that I could try in the meanwhile?

If it was a hdmi cable problem (I am using the original one that came with the 4K+), it should cause other problems too, shouldn’t it?

The TV is a Sony KD55XE9005.

Any ideas? Thanks

Hello again.

I enabled debug logging waiting for the issue to occur again. This morning it actually happened again. This time it did not show the “no signal” message rather a peculiar resolution (5x1075/45Hz) denoted by the TV with a black screen.

So I ssh-ed to the vero and run the grab-logs -A command. The return was “Logs available at

It should be something like, right?

What am I doing wrong here?

Reboot twice first.

Thanks for your reply. I indeed rebooted twice. I will try again.


ΟΚ, I rebooted thrice and now it seems to work.

I have also changed the hdmi cable and I am now waiting for the “no signal” issue to occur again.

I have the same issue since a long time. I am not sure if it started when I participated in the test for the new kernel of that I already had that problem before then.
I tried to create logs but I never succeeded. It sometimes took ten days before the issue started all the while having rebooted twice and turning on the debug logging. But when the issue occurred the logs did inly contain the webadres without the logfile: i.e. the same issue @zeronero has: and no additional file.

Now I simply go into ssh and reboot from the command line.

I also have a Sony but the 55 AF9. Vero is connected to a Denon receiver, but I also had that issue when connected straight to the Sony. Different HDMI cables did not change anything.

I decided to simply live with the issue :slight_smile:
But I do hope @zeronero will figure out the issue so I can make use of the solution as well…

Unforunatelly, while the “grab-logs -A” command" seemed to work for the first couple of days returning a address, now that I have checked it again, it once again returns the one. It seems that for some unknown (to me) reason it fails if the debug stays on for a certain extended time. Is it a bug?

I will never be able to provide a log file that includes the issue this way, unless it occurs within e.g. 48 hours.

Edit: Needless to say that I am extremely irritated by this debug log lines on the upper left corner of the screen while watching…

So, this morning the “no signal” message (to be exact a peculiar resolution 5x1075/45Hz and black screen) occurred again. I don’t know when exactly, the last time a checked yesterday night it was ok.
Due to the problem mentioned above I couldn’t get the logs with the grab-logs -A command. So I rebooted and then tested the grab-logs -A command again. This time it worked.

At some point in the file I found the “Kodi Old Log” line, so I am posting this log in case it is useful.

I hope that someone could pinpoint the issue.


1 Like

I am experiencing a similar issue intermittently.
I had the screen go black this morning while debug logs were enabled, couldn’t get the system to respond until I restarted the mediacenter through systemctl, but when I used the command grab-logs -A (before restarting the mediacenter) I got back the paste url that doesn’t work similar to what you have been getting…
Maybe as you have surmised it is due to debug going on for too long… and the logs are simply too big to upload?

Thanks for your reply.

We are already 3 people here with the same problem. I hope that the support team will look into it and come up with a suggestion or solution.

Just for statistic’s sake: I have the same problem after the v19.1 upgrade (regular Vero 4k, not plus). It happens almost daily. So far my only workaround has been to reboot via ssh.

Symptomatically it’s “just” missing the video HDMI output (directly connected). CEC input over HDMI still works, so I can blindly control the Vero via the TV’s remote as usual, there’s just no video output.


Yes, the CEC continues to work here too. Just the video output goes out.

Just an idea: try enabling the “Wake devices when deactivating the screensaver” option in the CEC Adapter settings as a workaround. I did so and haven’t seen the issue since then. Granted, it’s been just over a day :smirk:

In my case the “missing output” always occurred after I hadn’t used the Vero for a while, so the screen saver (in my case Black) was almost certainly active. Maybe the “waking” also triggers a video output reset/refresh…? :crossed_fingers:

OK, I set it as you did and now I am waiting to see…

In 5 days, the problem occured again. So, no solution for me, at least.

The problem still persists for me.

This is still on the list to investigate.


Thanks for your reply.

Hi all,

Same for me with Vero4k (normal) there is always a “black screen” / “no signal” since I upgraded to Kodi 19.1.
For me this happens EVERYTIME when I turned off the LG OLED TV after e.g. watching Live TV und turn the TV on again after 1-2h.
When I try to fix the issue by SSH into vero and running sudo service mediacenter restart but it does not bring back any picture on HDMI. I really need to run sudo reboot.

Hopefully @sam_nazarko finds out where the bug is…
THX in advance :wink:

PS: My kernel is Linux vero1 4.9.113-45-osmc #1 SMP PREEMPT Sun Aug 8 03:43:54 UTC 2021 aarch64 GNU/Linux, clean install from 3 weeks ago.


Sorry to hear this.

If you’re familiar with SSH, then please post some logs the next time it happens.

I’d also suggest updating to the latest version of OSMC which we will release in the coming days

To test this update:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb buster-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating. This will return you to the normal update channel. To remove the file:
sudo rm /etc/apt/sources.list.d/osmc-devel.list

Hi @sam_nazarko ,
Unfortunatly the update did “brick” my Vero4k after the reboot command. Currently the device is not even starting up with the bootscreen. :frowning:
Btw, I use an USB power adapter because my original vero4k power adapter is not working anymore.