LiveTV Video Stuttering after May Update

#1

I’m had tacked this to another thread because I thought I was having the same issue, but in my case it didn’t start until I upgraded to the May release. I realized posting to the end of a thread marked solved might not be the best choice, so I’m reposting.

I only have the problems with H.264 channels (I have MPEG2 channels that are fine), and only on my Vero 4K+ (the same channels that stutter on the 4K+ don’t have any problems on my Mac or Windows PC both running Kodi 18.2).

Recordings (either MPEG2 or H.264) are all fine. I’m using NextPVR as my backend.

Here is a full debug log:

https://paste.osmc.tv/ozuniqetew

The playback of the channel starts around 17:47:55.

Tv Headend Client skipping frames playing 1080 50fps h264 on Vero4K+ after May update
#2

Hmmm. There seem to be some rogue dts values in there. Stretching my video knowledge.

LiveTV Stuttering Fixed in June Update Returns with July Update
#3

Just FYI, I’ve tried some of the other fixes mentioned for stuttering video that involved setting bypass_prog or bypass_all to a different value, and that didn’t help. I’d like to stick on this version to help track the problem down, but over half my TV channels are unwatchable. This weekend I’ll probably have to revert to the older version (or start sleeping on the couch when my spouse gets mad at me), so my ability to assist after that might be limited.

#4

Have you tried Settings->Player->Adjust refresh rate to ‘On start/stop’?

Thinks: can you upload a kodi.log for Windows playing a h264 channel?

#5

I’m pretty sure I tried the refresh rate change, but I will check again when I get home (in Hawaii, so it’s still work time here). I’ll also generate a debug log from my Windows machine.

#6

OK, here’s the Kodi log from my Windows machine.

http://paste.osmc.io/jogugewuze.hs

Different channel, but it’s another of the H264 ones (and I had checked before that it wasn’t just one H264 channel, it’s any of them).

BTW, I tried with adjust refresh rate set as you suggested. I’m not noticing any improvement with that setting.

Thanks.

#7

Thanks for the log. I’ll see if I can find time to set up NextPVR and try to reproduce this.

I assume your NextPVR client is up to date?

#8

I have another topic open on the same issue. The only difference is that i’m using TVHeadend client.
I hope that this remark helps to narrow down the search for the cause of issue.

1 Like
#9

It is. Same version on both machines with same settings. I tried to eliminate all the variables I could. :wink:

#10

I noticed there were updates available today so I installed them. No change in my issue, although I didn’t necessarily expect a change, as it looks like the updates were VC1 related. A person can dream though.

:wink:

#11

@pkscout: Does this also happen if you disable timeshift on TVH?

image

Where is your timeshift storage path pointing to?

It looks to me that you watch timeshift instead of the live TV stream. Have you checked the setting at Settings->Live TV->Playback->Fallback framerate whether it is set to an appropriate value for your environment?

Could you also just temporarily try the TVheadend HTSP client as backend (just to see whether this issue is related to the used client)?

#12

I’m using NextPVR as my back end. I tried all the various options for timeshifting and real time in the NPVR addon with no luck. Given that the video is fine if played from Kodi on Windows or OSX, I’m a little hesitant to go looking at NPVR for the issue. It seems like the common theme between my issue and @catalin211is that we’re both streaming H264 channels from a PVR backend. My MPEG2 ones are fine. And H264 was fine until the May update.

#13

I set up a pi3B+ as TVheadend server with current OSMC staging und a TVheadend HTSP client on a Vero 4k. A twin DVB-C tuner (AVM DVB-C Wlan repeater) serves as TV adapter (sat->IP).
No way to reproduce the issue but the cable provider here only provides streams till

H.264, 50 fps but 1080 i instead 1080 p, Audio is AC3.

Sorry, running out of ideas for this. Here a screenshot how it is arriving at the Vero 4k:

#14

It seems both you and @catalin211 have Adjust refresh rate set to Off with your GUIs at 60Hz. That can’t help, but I’ve reproduced that setup and I don’t get any stuttering or other issues. Try setting it to On start/stop.

1 Like
#16

@grahamh I just tried it and it doesn’t help.

#17

@pkscout I setup NextPVR server on Win10 … quite cool implementation, really interesting for those want to run such stack permanently on Windows. After configuring a single DVB-C frequency on one of my AVM DVB-C tuners, I still can’t see any issue, even after long time running


Is there any chance that this is a network bandwidth issue between the Vero4k+ and your NextPVR server? Could you check that with iperf3?
I don’t know where your NextPVR server gets its data from but here the tuner’s data stream comes via ethernet LAN into the Win10 system and will be forwarded by NextPVR server using the same interface to the NextPVR client running on Vero, so this needs twice the bandwidth compared to playback of a recording from the Win10 system.

#18

Here are the iperf results. I think you’ll agree the network isn’t likely to be the issue, and if it was the network I would have expected it to be a problem before the May update.

[ ID] Interval Transfer Bandwidth Retr Cwnd
[ 4] 0.00-1.00 sec 106 MBytes 892 Mbits/sec 0 269 KBytes
[ 4] 1.00-2.00 sec 112 MBytes 943 Mbits/sec 0 269 KBytes
[ 4] 2.00-3.00 sec 112 MBytes 944 Mbits/sec 0 269 KBytes
[ 4] 3.00-4.00 sec 112 MBytes 942 Mbits/sec 0 269 KBytes
[ 4] 4.00-5.00 sec 112 MBytes 942 Mbits/sec 0 269 KBytes
[ 4] 5.00-6.00 sec 113 MBytes 945 Mbits/sec 0 269 KBytes
[ 4] 6.00-7.00 sec 112 MBytes 940 Mbits/sec 0 269 KBytes
[ 4] 7.00-8.00 sec 112 MBytes 938 Mbits/sec 0 269 KBytes
[ 4] 8.00-9.00 sec 112 MBytes 940 Mbits/sec 0 269 KBytes
[ 4] 9.00-10.00 sec 112 MBytes 945 Mbits/sec 0 269 KBytes


[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 1.09 GBytes 937 Mbits/sec 0 sender
[ 4] 0.00-10.00 sec 1.09 GBytes 936 Mbits/sec receiver

I’ve tried various settings with adjust display refresh, and none of them changed anything. In the system settings I did change the refresh rate to 50 and leave adjust display refresh off then it gets better. The stuttering happens less frequently (maybe once every 20 - 30 seconds instead of every 5 seconnds) and when it stutters it’s less of a stutter. But it’s definitely still there. The other thing I noticed is that in my case the channel is coming through as 1080p 60Hz. Everyone else trying stuff out seems to be at 50Hz. I’m trying to see if I can change the source to some other resolution or refresh rate and test with that.

I want to reiterate that this didn’t happen before the update and does not happen when playing back live tv on Kodi for Windows or Kodi for OSX.

#19

Yes, live TV on OSMC seems to be more popular in Europe. We can’t test 60Hz over here.

#20

@pkscout Just to be sure: You need to run iperf3 in reverse mode (option -R) otherwise you test the sending bandwidth from the Vero to the NextPVR server, only.

#21

Here are the reverse iperf results. Again, hard to see how this is a network issue.

Reverse mode, remote host 172.16.1.5 is sending
[ 4] local 172.16.1.3 port 51947 connected to 172.16.1.5 port 5201
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 112 MBytes 941 Mbits/sec
[ 4] 1.00-2.00 sec 112 MBytes 941 Mbits/sec
[ 4] 2.00-3.00 sec 112 MBytes 943 Mbits/sec
[ 4] 3.00-4.00 sec 112 MBytes 943 Mbits/sec
[ 4] 4.00-5.00 sec 112 MBytes 943 Mbits/sec
[ 4] 5.00-6.00 sec 113 MBytes 944 Mbits/sec
[ 4] 6.00-7.00 sec 113 MBytes 944 Mbits/sec
[ 4] 7.00-8.00 sec 112 MBytes 944 Mbits/sec
[ 4] 8.00-9.00 sec 112 MBytes 943 Mbits/sec
[ 4] 9.00-10.00 sec 112 MBytes 939 Mbits/sec


[ ID] Interval Transfer Bandwidth
[ 4] 0.00-10.00 sec 1.10 GBytes 943 Mbits/sec sender