RPi2 composite failure

I upgraded from Leia to Matrix, and composite stopped working. When I plug in HDMI, all is good.
Clean install of Matrix, same thing.
It shows the splash screen, then some text, then a black screen.
SFTP works, I can access the filesystem.
SSH does not work, I do not get a login prompt.
Problem is consistently only when using composite. When I use HDMI, everything works perfectly, I have display, audio, SFTP, and SSH.

We need useful diagnostic info.

Will the log survive a second reboot?

That’s the only way that I can then get to a console to run grab-logs -A

So my process will be:

  1. Enable logging
  2. Power off
  3. Change the HDMI cable for composite
  4. Boot, wait for the system to hang
  5. Yank the power
  6. Change the composite cable for HDMI
  7. Boot
  8. grab-logs -A
  9. Post URL

Will that work?

Log of boot with Matrix:

Log of boot with Leia, for comparison:

I’ve got exactly the same issue and behaviour on a RPi3. Got the blue splash screen and then everything goes black. I saw that OSMC is working because i’ve got a wifi dongle plugged that flashes (because the internal broadcom chip has been down for a while). When plugged via HDMI, everything is fine.
More over, the TV seems to receive a signal because when i unplug the composite cable, i’ve got a “no signal” info that pop out when cable is plugged.
Try on 3 SCART TV, same problem on the 3.

I’ve checked the config.txt and it is perfectly normal (setting set to PAL 4:3 ).
EDIT : display settings have been set using “My OSMC” menu while plugged with HDMI.

I’m not sure that this is supported.

I’ll check with @popcornmix.

That will make me quite sad.

It happens just the same to my rpi3. I’ve got a vero 4k+ and a rpi3 and both upgraded yesterday. Some issues with the network, ip manual reverted to dhcp and things like that, and with the audio (I had the old bluetooth hack around), but this thing with the hdmi is beyond my league. It won’t start mediacenter without a monitor plugged in, and it won’t let me in through ssh either. With a monitor at the start everything is fine, you can plug it out after the system is up.

Update: system starts fine, and other network services too. Mediacenter do not. When you try to ssh, a new session is open in osmc, but remote terminal won’t show promt, just freezes. Later today, I will try to see more.

And a SCART monitor is not seen has a “valid” monitor thus the boot seems not to end properly.
I’m thinking we’ll need to downgrade back to leia if we want our composite output to work :frowning:

I’ve given it another try. There is a null pointer at the kernel logs when hdmi is not plugged in, but I found no other difference; After several tries (and failures) at paste.osmc.tv, I just paste some of the logs. Sorry for the inconvenience.

:: soc:gpu: Worker [189] failed                                                    
:: Worker [189] terminated by signal 11 (SEGV)                                     
:: ---[ end trace cd48899973ccec37 ]---                                            
:: Code: e5953034 e3a01004 e5150008 e2800010 (e5937280)                            
:: r7:0000017b r6:c1563300 r5:00000000 r4:018e69a0                                 
:: 5fe0: 7edd9158 7edd9148 76e6f1cd 76f1fd92                                       
:: 5fc0: 018e69a0 00000000 c1563300 0000017b 018f2ad0 00471898 00000000 018f8928   
:: 5fa0: 018e69a0 00000000 0000001d 76e7559c 00000000 018e7e00                     
:: Exception stack(0x82ff5fa8 to 0x82ff5ff0)                                       
:: [<801ecaec>] (sys_finit_module) from [<801001e4>] (__sys_trace_return+0x0/0x1c) 
:: r4:81205008                                                                     
:: r10:0000017b r9:82ff4000 r8:80100204 r7:0000001d r6:76e7559c r5:00000000        
:: 5740: 82ff579c 82ff5750 7f37092c 7f3871e4 82ff5794 82ff5760 7f38d198 7f39086c                   
:: 5720: 84113040 84136780 84113040 83064a84 7f3980b0 00000000                                     
:: Stack: (0x82ff5728 to 0x82ff6000)                                                               
:: Process systemd-udevd (pid: 189, stack limit = 0x41baf685)                                      
:: Control: 10c5383d Table: 0319006a DAC: 00000055                                                 
:: Flags: nZCv IRQs on FIQs on Mode SVC_32 ISA ARM Segment user                                    
:: r3 : 00000000 r2 : 00000003 r1 : 00000004 r0 : 81ac0a10                                         
:: r7 : 83064a84 r6 : 84113040 r5 : 83064a84 r4 : 00000000                                         
:: r10: 83062800 r9 : 00000000 r8 : 7f3980b0                                                       
:: sp : 82ff5728 ip : 82ff5750 fp : 82ff574c                                                       
:: pc : [<7f387248>] lr : [<7f37092c>] psr: 60010013                                               
:: LR is at vc4_crtc_atomic_enable+0x74/0x560 [vc4]                                                
:: PC is at vc4_hdmi_encoder_pre_crtc_configure+0x70/0x620 [vc4]                                   
:: Hardware name: BCM2835                                                                          
:: CPU: 0 PID: 189 Comm: systemd-udevd Tainted: G C 5.10.32-2-osmc #1                              
:: Modules linked in: vc4(+) cec drm_kms_helper brcmfmac drm brcmutil drm_panel_orientation_quirks 
::   snd_soc_core snd_compress hci_uart snd_pcm_dmaengine btbcm snd_pcm bluetooth sha256_generic     
::   snd_timer ecdh_generic ecc snd syscopyarea sysfillrect cfg80211 sysimgblt joydev fb_sys_fops    
::   backlight rfkill raspberrypi_hwmon i2c_bcm2835 bcm2835_codec(C) bcm2835_v4l2(C) v4l2_mem2mem    
::   bcm2835_isp(C) bcm2835_mmal_vchiq(C) videobuf2_dma_contig videobuf2_vmalloc videobuf2_memops    
::   videobuf2_v4l2 spi_bcm2835 videobuf2_common videodev mc vc_sm_cma(C) uio_pdrv_genirq uio        
::   fixed ip_tables x_tables ipv6                                                                   
:: Internal error: Oops: 5 [#1] PREEMPT SMP ARM                                                    
:: [00000280] *pgd=00000000                                                                        
:: pgd = 0c713564                                                                                  
:: Unable to handle kernel NULL pointer dereference at virtual address 00000280                    
:: 8<--- cut here ---                                                                              
:: debugfs: Directory '3f902000.hdmi' with parent 'vc4-hdmi' already present!                      

Well, last shot was a fresh install in a different sd card. That didn’t work either. Still no mediacenter, no ssh prompt.

It’s a RPI3B+, with a tv pihat, nothing else.

I believe that this is a bug.

Hopefully it will be resolved upstream in the future.


1 Like

Today I’ve tried kodi matrix (backports) on a buster raspios and libreelec kodi matirix (beta) on a RPI4. It seems both have issues when running without a hdmi thing plugged in. The libreelec at least show web interface properly and prompts to ssh, but no sound at the jack.

Might be related to Kernel OOPS after update to v19.

Sam suggests trying an update to the buster-devel channel which currently contains kernel 5.10.60-1-osmc, including a commit that looks related and that was integrated with 5.10.51.

I have Rpi3B+, new OSMC installation and try get it working with composite video. The blue OSMC logo displays fine as some startup texts, but then display turns black (if unplug AV-cable get ‘No signal’, so it’s actually sending black). On HDMI cable it works just fine. I did the buster-devel update instructed above, it installed 5.10.60-2-osmc. I can connect with SSH, tvservice reports PAL display which is correct. I can also connect with web-browser on HTTP-address. My logs at: https://paste.osmc.tv/nexahireco

What would you instruct me to look at?

tvservice -s
state 0x80001 [PAL 4:3], 720x576 @ 50.00Hz, interlaced