Update end Oct - OSMC does not boot anymore -Vero HW failure?

Dear friends,
I had an “update available” up for a couple of weeks. Today I decided to reboot to update but something has gone very wrong :frowning:

Here is what I see now. First a clean OSMC screen and then after a few minutes the messages you can see on the photo. Tried powering off and then on again but no gain.

Vero is still running the original SD card which I have never had to reinstall / replace until now.

Thanks for any suggestions.

Do you know which version you were on before?

Can you unplug the attached USB and try again?

Sam

Hi Sam,
thanks for attempting to solve this.
I don’t know exactly but I updated fairly often until now and the update notice has been on for a few weeks (around 3).

I had attached an USB SSD to have torrents on it. Now per your instructions I have removed it. Unplugged power and rebooted.

Unfortunately nothing changed.

I am now downloading an OSMC for Vero on another MicroSD and will see what gives.

PS Might there be any value in extracting the original SD mount it on my Mac and see if the fs is ok ?

I’m assuming you mount this SSD by fstab? Sounds like you may not be using all the appropriate flags for mounting there.

Hi ActionA !
Frankly I don’t remember. The SSD was mounted and working allright.
Now it’s not there anymore.
Unit still hangs booting.
Thanks a lot.

Automounted drives show up in /media while your’s is in /mnt so that would indicate that you have used fstab. If you plugged the SDcard into a linux machine, you could access /etc/fstab and remove or comment out the line for that drive and it would likely boot. Then we could move on from there.

1 Like

Thanks ActionA.
Put Vero’s microSD into my Mac (which has linux fs drivers) and edited out two lines from my /etc/fstab:

#//192.168.174.9/WD1TB /mnt/WD1TB cifs username=xxx,password=yyy,uid=1000,gid=1000,iocharset=utf8,sec=ntlmv2 0 0

#/dev/sda1	/mnt/SSD128 ext4	defaults,noatime 0 0

And now OSMC booted, updated and we’re almost back. Thanks a lot ! Just 2 more questions:

First line is to mount a CIFS share with all my movies coming from a second RPi.
Second line is a locally mounted (USB) SSD with local files used by my torrent client.

How can I mount the ssd properly in the same mountpoint without getting in this rebooting problem ?

The CIFS mount behaves well and does not interfere with reboots but I must always issue a sudo mount -a to have it back after a reboot.

Thank you !!!

You should use the following mount options for both mounts:

noauto,x-systemd.automount,nofail

I am starting to be afraid I have an HW issue with Vero itself (it’s one of the early Rev.1 units).

After modifying the fstab lines as you suggested Vero did not reboot at all.

I therefore found an IDENTICAL microSD to the original one.

The one on the bottom with the greyish felt pen marker on top of the micro logo is the new (used only twice before) card:

I installed OSMC installer onto it and inserted it into the Vero.

It booted and formatted/downloaded and installed stuff but then when it tried rebooting I got the following:

Not sure as to what else should I try. Suggestions ?

I’ll be traveling to London an a few hours and will not be able to act physically here at my house but please help me.

Thanks in advance.

Mine is an early preproduction unit (it doesn’t even have the logo on the top :smiley: ) and no problem here.

Did you add those options only to your two extra mount points, not to the original / and /boot partitions I hope ?

The issue you show in the very first picture of this thread is one that we have been trying to solve in another thread:

This seems to be affecting a small number of units when updated to the recent kernels (July update onwards) and despite several months attempts Sam has not been able to get back a confirmed affected unit from a user so we can see and work on the problem first hand.

There is also a strong possibility that the problem is a compatibility issue between the newer kernels and certain batches of Sandisk cards - Sam has also asked affected users if they could try a different brand of card to see if that helps but again nobody has actually done so to date.

It would be very helpful if you were able to try a different card of a different make than Sandisk to see if you have the same “Dependency failed for /boot” issue when trying to install the October version. Even if you temporarily borrow a card from a camera etc. Anything from about 4GB up (maybe even 2GB) should be enough for a test to see whether it boots or not.

If we could confirm for sure whether a different card works OK or not then it would help narrow the issue down to a batch of Vero’s or a batch of Sandisk SD cards.

Ok thanks. I’ll definitely be able to experiment with different card brands. I tried with an identical card (which I had since a while back and got here in Italy for a camera) to avoid introducing more variables.

I’ll be back in Rome next Monday, as I’m enjoying London’s fog right now on a business trip !

Take care and talk soon.

Just back at home. Could not find any non-Sandisk MicroSDs !!!

Will go buy one tomorrow if necessary.

Just as another test DLed OSMC on same Sandisk which does not seem to work with the Vero and it works well with an RPi2 (mod B 1GB)

If necessary I can send my Vero to Sam to see if he can sort this out.

TC

Hi guys
I’ll reply in here as it’s a similar problem.

Did an update a few days ago on the Vero - via the My OSMC menu and updates
On restart it only shows the OSMC spash screen now

I have no experience using linux commands & only have a chromebook in the house!

Any tips on what to do next
Can I re-install OSMC using a chromebook?

Liam

Hi,

Long shot, but can someone try this:

Sam

Hi

Did the file replace using chromebook (mentioned in case that made any diff)

Inserted micro-SD into Vero while off and rebooted

Still stuck at OSMC logo screen
I don’t see any coding in the top left (never have) like others have mentioned

Hi

Does not sound like the same issue then. You can re-image the card from osmc.tv/download. On your Chromebook you may have to manually image the SD card with dd. If you have any trouble, send me a PM or start a new post and I’ll be glad to help

Cheers

Sam

OK
Thanks
new thread for my OSMC problem

1 Like

Ok downloaded Oct 2015 update on a non Sandisk 8GB MicroSD. Now in vero, formatting, installing files, installed succesfully with full bar, reboot, me trembles, OSMC splash screen and … IT FRIGGIN WORKS … :smile:

Now this is really unexpected !

So I had problems with several identical to the original Sandisk 8GB MicroSDs which have been bought in different countries (UK and Italy) and in different times, from both EBay and amazon … go guess.

I will test extensively the MicroSD with hwtest but I am pretty sure they’ll come out clean.

Will report if the situation changes again uncovering a non 100% replicable problem. For now all seems ok.

Thanks a lot.

odoliam,
while your problem might be different please note that the errors at the top left of the OSMC screen took a few minutes to appear. Until then all you could see was the simple and naked OSMC splash screen.

If you can, install the June update on the bad card (last working update for those affected) and run these commands:

wget http://apt.osmc.tv/pool/main/v/vero-kernel-osmc/vero-kernel-osmc_1.8.7_armhf.deb -O vero-kernel.deb
wget http://apt.osmc.tv/pool/main/v/vero-source-4.1.12-3-osmc/vero-image-4.1.12-3-osmc_3_armhf.deb -O vero-image.deb
sudo dpkg -i vero-kernel.deb
sudo dpkg -i vero-image.deb

and report back

Cheers

Sam