VC-1 not working (stuttering) with latest Leia and Kernel builds

Not sure when it got “broken”. Few versions ago it still worked fine but now it’s failing.

With zero diagnostic information provided, I’m not at all sure how anyone can assist you.

I’ll try to get those this afternoon but it’s a well known and a recurring issue.

From time to time it arises again. It’s easy to check it in the forums.

I haven’t been able to reproduce this here with some VC-1 content on the latest version of OSMC.

Can you elaborate on this?



Then why are you not addressing this in one of the existing forum threads if “it’s well known?” We prefer to try to keep information organized for ease of reference. Spreading one issue across multiple threads is not helpful from a support perspective.

Some of those threads are several months, or even years old. That’s why I opened a new one.

But don’t worry, this afternoon I’ll paste a full debug log.

Thanks for answering.

In those two posts regarding Vero, you will see that the issue was fixed over a year ago. The second post is a fix for the issues outlined in the first and users confirmed it as working; so we included it in an update.

The last post is regarding Raspberry Pi, rather than Vero, so isn’t relevant however.


Here is a summary of my installed versions

osmc@osmc:~$ dpkg -l | grep vero | grep ii
ii vero3-device-osmc 1.4.2 armhf Vero 3 metapackage
ii vero3-earlysplash-osmc 1.0.3 armhf Vero3 logo partition
ii vero3-ftr-osmc 1.5.6 armhf First-time-run scripts for OSMC
ii vero3-fwenv-osmc 2016.01-2 armhf firmware tools for OSMC
ii vero3-libamcodec-osmc 1.2.0-3 armhf libamcodec
ii vero3-libcec-osmc 4.0.2-6 armhf libcec
ii vero3-mediacenter-osmc 17.8-399 armhf Media Center package for OSMC
ii vero3-userland-osmc 1.4.2 armhf Vero 3 userland package
ii vero3-wifi-osmc 1.1.0-13 armhf Broadcom patchram implementation for Vero
ii vero364-image-3.14.29-135-osmc:arm64 135 arm64 Linux kernel binary image for version 3.14.29-135-osmc
ii vero364-image-3.14.29-138-osmc:arm64 138 arm64 Linux kernel binary image for version 3.14.29-138-osmc
ii vero364-kernel-osmc:arm64 3.9.131 arm64 Kernel meta package bringing in the latest OSMC kernel for this device

And here is my log

Have you tried with Kodi v17 (Krypton)?
It looks like you are running an experimental Leia build.

Yes, I’m using latest Leia build and latest kernel, as I stated at the beginning.

And no, I haven’t tried krypton. I got issues trying to get back to v17 without a full reinstall about a month ago, so I’m using Leia builds with almost no issues to be honest.

Feel free to move this thread to another section if it fits better. I can wait for a solution.

Edited just to point out that the Kernel is the 3.14.29-138, so a more recent version than the december one.

There are some patches missing in Kodi v18 (this explains the behaviour)
When Kodi v18 is stable, this will be fixed.

If VC-1 playback is critical, we recommend staying with stable versions of OSMC (Kodi v17.6). There are still a number of show-stopper bugs with Kodi v18.

But the Kodi v18 stable release is not far off.


With Kodi 17.6 VC-1 playback works smooth and perfect, problem was solved in 2017!

1 Like

Good to know I always encoded my VC-1 stuff to H264 just to be safe before playing on vero

It’s an old topic, but since the newest update with Kodi18, VC-1 playback looks to be broken again. I tried different video’s, and all of the VC-1 items are stuttering now. x264 and x265 are playing flawless.

Do you need any information from me to fix this?

@timadriaans I think the fix is in staging already (stretch-devel).

1 Like
  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

1 Like

Thanks guys, i’ll try to check this tonight!

This fix is now in the regular update channel. Just update as normal.

1 Like

Even better :slight_smile: much appreciated again!

Problem solved!