Video improvement details


#1

Hi,

In the October update we released a number of video improvements re. HDR and 4K playback for Vero. We understand that some users have been experiencing issues with them.

Users that would like to revert these changes can do so in the following way:

Go to My OSMC -> Updates -> Manual Controls -> Apply Hotfix. Enter the following code and press OK:

[deprecated]

After a few minutes, your system should be downgraded.

Cheers

Sam


Kodi won't play video in some time after restart
Black screen
2160p gone with last update
Few playback issues on my new Vero 4K+
#2

Hi Sam, if you run this Hotfix is there a way to undo it?


#3

When they find the root of the problem, either a new update or another hotfix will be published with it. Normally if you are having a problem, then there would really be no reason to remove the hotfix and to go back to the release with your problem.


#4

You can update to the latest kernel again.
But you should only be downgrading if experiencing a problem.

Sam


#5

Hi Sam, i am asking as i was wondering if it will help with the problem i am having here:
https://discourse.osmc.tv/t/oct-update-and-10-bit-movies/


#6

Tried hotfix and so far so good :slight_smile:


#7

I also had to install the hotfix on my Vero4k+. Switching to 4k for playback resulted in no image at all.

Works fine with 4k HDR with the hotfix.

Display chain: Vero4k+ – Denon X6500 – Sony VW570


HDR Autoswitch causing issues on my LG OLED65C8
HDR Autoswitch causing issues on my LG OLED65C8
#8

Hotfix fixed those blackouts and white flashing points issues on 4K HDR playback for me also (Panasonic Oled CZ950 display).


#9

Just wanted to say that I had to apply this hotfix also. 4k movies were not working anymore. (Vero to marantz to lg oled)


#10

Hi,

How can I undo this hotfix? I applied it beceause I’m having an issue on only one 4K HDR file. Issue beeing blacks are grey. But after applieing this hotfix I’m having this issue on a lot more 4K HDR movie files.

You mentioned previously in this topic that I can reaply the latest kernel again. How do I do that?
Thanks!


#11

It would be better to work out why this is happening, as we are about to make these improvements available as an update.

A log when you play affected material would be helpful

Sam


#12

Sam,

Ok, Will we continue troubleshooting this issue in this thread?


#13

That works for me


#14

Hi everyone,

I was in a similar boat, Vero 4K, LG C7 TV and Denon receiver and never used the HDR auto switching feature. Whenever I did, I’d get a black screen and would have to stop the video.

So much like others here, with the November update I could no longer play 4K files without trying the hotfix mentioned above (UI set at 2160p also gave black screen).

So my question is, what did that hotfix actually do? I can play 4K files again but occording to what my Denon says, I’m only getting 8bit color depth output now.

Does this hotfix basically force 8bit until the next full release?

Thanks for the continued support!


#15

It reverted you to the August release. Please try the latest testing release


#16

Hi Sam,

I am having this black screen issue with my Vero 4K+ that’s got the latest update from december 2018.
I tryed using this Apply Hotfix “[deprecated]” but nothing happens to my device…
Could you give me another code to retrieve the previous version which was working fine here?
Thanks in advance.

Jorge.


#18

It would be better if we could help fix the problem for you. Otherwise you may be stuck on an old release for ever. Note that just because it’s a blank screen doesn’t mean it’s the same underlying issue so we would like to know if it’s something new. Please update again using MyOSMC, describe exactly the situation when you get a blank screen (screen resolution, framerate) and post debug logs.


#23

Hi,
I’ve noticed that my Vero 4K issues were happening when I set the main screen resolution to 3840x2160 at 60hz… Whenever I stopped a movie, I got a black screen and needed to restart the OSMC. All the movies I tested had been converted in 4K.
After I set my Kodi to 1920x1080 at 60hz, the black screen issues have stopped. I’m leaving 2 screens of the system log at the time the last black screen appeared, so that you can figure out what exactly was going on here.
My television is an LG OLED C8 (latest model).
Thanks in advance,
Jorge.



#24

Do not set the GUI to 4k. GUI should be set to 1080p and Adjustframe Rate set to Start/Stop or Always.


#26

Maybe the GUI should just lock out 4K to prevent people setting it that way in the first place. Maybe with some kind of disclaimer in the menu. Unless one frequents these forums, you’d never know not to set the GUI to 4K if you have a 4K TV.