[Wiki] Install and configure mysql server and clients


Yes I did that command.
The database works fine on the first device.
The second device saw the database after I deleted all the sources and library info that was already on it plus I Copied these files over from the first device favourites.xml ", " sources.xml ", " mediasources.xml ", " passwords.xml "

The video files play (on nas) but the music files (on sdcard in first device) don’t play on the second device.

Get this error in the log.

DEBUG: CPlayerCoreFactory::GetPlayers: matched 0 rules with players
11:03:02.121 T:1925896704 DEBUG: CPlayerCoreFactory::GetPlayers: adding audiodefaultplayer (PAPlayer)
11:03:02.121 T:1925896704 DEBUG: CPlayerCoreFactory::GetPlayers: for video=0, audio=1
11:03:02.121 T:1925896704 DEBUG: CPlayerCoreFactory::GetPlayers: for video=1, audio=1
11:03:02.121 T:1925896704 DEBUG: CPlayerCoreFactory::GetPlayers: adding player: VideoPlayer
11:03:02.121 T:1925896704 DEBUG: CPlayerCoreFactory::GetPlayers: added 2 players
11:03:02.133 T:1718354688 DEBUG: Skin Helper Service --> Kodi_Monitor: sender xbmc - method: Playlist.OnAdd - data: {“item”:{“id”:918,“type”:“song”},“playlistid”:0,“position”:3}
11:03:02.154 T:1925896704 ERROR: Init: Error opening file musicdb://albums/406/918.mp3?albumid=406
11:03:02.154 T:1925896704 ERROR: CAudioDecoder: Unable to Init Codec while loading file musicdb://albums/406/918.mp3?albumid=406
11:03:02.154 T:1925896704 WARNING: PAPlayer::QueueNextFileEx - Failed to create the decoder
11:03:02.154 T:1925896704 DEBUG: OnQueueNextItem: play state was 1, starting 1
11:03:02.154 T:1925896704 DEBUG: OnPlayBackStopped: play state was 1, starting 0
11:03:02.155 T:1925882624 DEBUG: CAnnouncementManager - Announcement: OnStop from xbmc
11:03:02.155 T:1925896704 ERROR: Playlist Player: skipping unplayable item: 3, path [musicdb://albums/406/918.mp3?albumid=406]
11:03:02.155 T:1925896704 DEBUG: Playlist Player: no more playable items… aborting playback
11:03:02.155 T:1925882624 DEBUG: GOT ANNOUNCEMENT, type: 1, from xbmc, message OnStop
11:03:02.184 T:1659372288


Well for them to play you would first need to share them (e.g. via samba) and then either add them to the Library on both devices via the Network Share name or alternatively use path substitution on the second device


I’ve installed samba from the myosmc program addon but not sure if I need to change anything after that as adding the source on second device smb://(ip address of first device)/home/osmc/Music throws up error “file exits” I’ve tried it without a password, with the default osmc password and also the password I made for remote control via http.

When adding the network location i’ve got the shared folder set as home/osmc/Music

I’ve rebooted raspberry pi but still them same error



I think you might have mixed up things with copying your sources and password files. Also it might be best if you use fstab based mounts as you anyhow need to find a way to align both systems (either by using same mounted folder name or via the path substitution)