4k+ CEC EARC issue

Been using the Vero for 5 years but have had both of them off for last few months while I wait for this to be fixed. However as that seems to not be happening i would like to rollback to a working version.

To do so I have a few questions if someone is able to advise.

What version do I need to rollback to?
Are there any instructions on how to rollback?
Will my current settings be maintained?


Hi Rakesh,

You can use the OSMC backup tool to backup and restore settings; provided that the version you downgrade to uses the same major release of Kodi (i.e. 19.x).

People seem to have reported success using the 2022.03 version of OSMC.

We are still looking in to this.


So it seems I was already on 2022.10 but I have now updated to the latest version as of last week.

So far no issues with CEC whereas on 2022.10 it was happening daily.

Oh, I wish I had been aware of this issue earlier. We experienced the same problem with our Yamaha soundbar, which stopped functioning, leaving us to rely on the TV’s built-in speakers. We examined all the settings and cables related to the soundbar, and were convinced that the soundbar was broken.

Today, we received a new soundbar, but were unable to obtain any audio from the eARC port. Surprisingly, when I removed the cable from the Vero 4K+ device, all the issues were resolved. It turns out that our old soundbar was not actually broken.

It appears that the problem is still unresolved?

We haven’t made any public changes yet, indeed.

Thank you for the reply. Is it true that I need to downgrade the firmware as someone stated here? 4k+ CEC EARC issue - #16 by speedy_kevin

It may help resolve your problem, it may not.

Where can I find the 2022-3 release? The download page does not list this release anymore…
This to resolve the CEC issues I am facing since introducing a Vero 4k+ in my setup…

I had a similar issue and created the thred below, just posted a descovery I have made there.

Found the 2022-03 image here: Index of /osmc/osmc/download/installers/diskimages


since i am stick with this issue too i would like to contribute my findings.
My Setup:
TV: Philips 55OLED806/12
Soundbar: LG SPD75YA
Vero4K running on latest FW (7/23)

The TV is connected to the Soundbar through HDM2 (eARC) Channel
Vero4k sits on HDM1 Port

First of all i got these weired standby issues of Vero4k and CEC stops working. Bit i think i could fix them by setting the behvaiour of the standby command to the Vero 4k to igonre. So no more red light if i switch of the TV.

But the eARC connection seems to have stopped and no audio from the soundbar and if i activte it from the TV the CEC functions (button pressing to go through menus seems to be buggy too.
I was running cec-client on the vero4k to see whats going on and i see:

DEBUG:   [           89905]     device Audio (5) status changed to present after command set system audio mode
DEBUG:   [           89905]     >> Audio (5) -> Broadcast (F): set system audio mode (72)
TRAFFIC: [           90736]     >> 5f:84:20:00:05
DEBUG:   [           90736]     Audio (5): physical address changed from ffff to 2000
DEBUG:   [           90737]     >> Audio (5) -> Broadcast (F): report physical address (84)
TRAFFIC: [           91549]     >> 5f:87:00:e0:91
DEBUG:   [           91549]     Audio (5): vendor = LG (00e091)
DEBUG:   [           91549]     replacing the command handler for device 'Audio' (5)
DEBUG:   [           91549]     Audio (5): CEC version 1.3a
DEBUG:   [           91549]     Audio (5): menu language set to 'eng'
DEBUG:   [           91549]     >> Audio (5) -> Broadcast (F): device vendor id (87)

So it seems that Vero4k will take control of the soundbar and not the TV. And after that i could hear audio from the soundbar.
I am realy no expert in CEC and eARC but is this intended?

If you are not married to using CEC, this is easily resolved by using a CEC-less HDMI adaptor or killing pin 13 on your HDMI cable.
I have more HDMI cables laying around than I know what to do with so I killed pin 13 on one of them and used that for my Vero for my wife and children while I’m at work.
I have settings that work well for me and avoid the CEC issues everyone experiences while maintaining CEC functionality and some have had success using those settings but if it doesn’t work for you then physically blocking CEC is your best bet and then just use multiple remotes.

One of the reasons I bought the Vero4k+ is the exceptional support provided by Sam and the team. Also nice to support a company from the same country.
In this case though the problem is affecting a small percentage of the OSMC userbase, still a considerable amount of people.
I’m disappointed that the issue is now going on for 10 months or so. Sam ensured us it would be fixed, I’m losing confidence.

I’m now backup my .kodi folder and will downgrade to OSMC_TGT_vero3_20220314.img.gz :frowning:

I am still looking at it - but I can’t fix what I cannot reproduce.

I’ve received logs from some users but they’ve usually been after a reboot (so problem isn’t visible) or not captured the issue when it occurs.

I am working with what I can but it is somewhat a stab in the dark at this point. It gets more complex because some users have reported the problem as solved.

I then reverted CEC to the exact version it was in the image you refer to, and yet users still didn’t report it as fixed. So I am somewhat puzzled.

But still working on it.

@sam_nazarko , I have two vero4k’s…one is now on the march 2022 version. And one is remaining on the latest osmc version.

If you provide step by step instructions on what I need to do to send you logs I would be happy to assist.

IMHO, CEC is a hot mess and different manufacturers have implemented it in non-standard ways.
LG is one of those companies.
And many Vero users have LG OLEDs (I know it happens with other TVs too).
It also gets messy with various sound bars and receivers.
My point is, the Vero user base is probably the type of people most likely to be affected by the poor standardization of CEC.
As an example; on many LG TVs disabling CEC (which they call SimpLink) also disables eARC/ARC.
There is no reason, according to CEC “standards”, that these two should be married to one another.
The fact that they are is probably a good indicator that LG is doing something non-standard with the CEC pin.
Grounding can be an issue too with CEC and HDMI (I have seen it at customer’s homes).
No one wants CEC to be a non-issue more than myself, trust me, but the OSMC team can only do so much considering the fault is usually born somewhere else in the chain, and it may be in the hardware design and unpatchable via software.
I believe the OSMC team has done everything they can short of purchasing large amounts of various TVs and AV equipment to test various configurations and something of that scale would be unreasonable to expect from such a small outlet like OSMC.

You raise some interesting points. I was of the view that my setup worked perfectly until an OSMC update. I had hoped it would be easy enough to identify what CEC related code had been updated and roll that back. Perhaps not easy if Debian was updated to next major release.
I hadn’t mentioned my setup because lots of people with different HW had the same issue, I have LG B7 OLED and Samsung HW-MS650 soundbar. Of course Sam and the team only have easy access to setups in their homes. I did offer Sam SSH access, I’m not sure he noticed the offer or how useful it would be.

Here also similar issues for months now. I have Vero 4K connection to my Denon receiver and the Denon Receiver with my TV. If the Vero 4K HDMI connection is in the received the sounds works good for the Vero 4K, but if I leave the HDMI in and switch off my receiver. And then start for example the TV (LG) with the Netflix app then the receiver does not respond. When remove the Vero 4K HDMI cable and start the TV again then the sound does work via the TV. Is this something related or another (known) issue?

It sounds related to me, but note that there could be two different things going on with different people. There can be a communications/software only related issue where something isn’t jiving with how the devices are talking to each other. There can also be a physical/electrical fault whereas through either a faulty device, or a setup where there becomes too many devices, too long of a run on the communications line, etc., a situation where pin 13 drops low and communication stops. As it is a single shared line this means all devices loose CEC. One example of this would be devices (like the Vero 4K) who have pin 13 electrically connected to ground and pull up the line when connected to power so if you pull the power cord it stops all connected devices from talking on the CEC bus. In situations where completely powering off is required (someone off grid or particularly concerned with vampire power perhaps) then physically disconnecting pin 13 and losing CEC on just that one device may be a prefered option.

Ok, this is quite technical for me and since it always worked good I find it hard to believe it has to do with a faulty device.

I would like to get this sorted. I preferably don’t want to look into buying a different mediaplayer.