Slow video start up

This is not since 19.1 but since the update yesterday. Now when playing some TV shows which I know had functional HDR, this no longer kicks in. If I try a film with HDR, this does. See log

Also, since full 19.1 update, the spinning up of local drives is much slower, taking between 5-10 seconds before trying to play content.

https://paste.osmc.tv/kocobotoxe

2021-08-19 11:15:49.270 T:3381     INFO <general>: ffmpeg[0xb4403b80X]: Input #0, matroska,webm, from '/media/OneTouch/TV5/Ted Lasso/Season 1/Ted Lasso - S01E01 - Pilot WEBDL-2160p.mkv':
2021-08-19 11:15:49.270 T:3381     INFO <general>: ffmpeg[0xb4403b80X]:   Metadata:
2021-08-19 11:15:49.270 T:3381     INFO <general>: ffmpeg[0xb4403b80X]:     encoder         : libebml v1.4.2 + libmatroska v1.6.4
2021-08-19 11:15:49.270 T:3381     INFO <general>: ffmpeg[0xb4403b80X]:     creation_time   : 2021-07-12T06:08:01.000000Z
2021-08-19 11:15:49.270 T:3381     INFO <general>: ffmpeg[0xb4403b80X]:   Duration: 00:30:55.98, start: 0.000000, bitrate: 21665 kb/s
2021-08-19 11:15:49.280 T:3381     INFO <general>: ffmpeg[0xb4403b80X]:     Stream #0:0(eng): Video: hevc (Main 10), yuv420p10le(tv, bt709), 3840x1920 [SAR 1:1 DAR 2:1], 23.98 fps, 23.98 tbr, 1k tbn, 1k tbc (default)

That clip is not HDR yuv420p10le(tv, bt709).

Apologies, you are correct. It appears a mixed bag with some of them having HDR and some not. I incorrectly assumed! :slight_smile:

Any idea bout slow spin up of discs (if that’'s what it is)?

Not my department, sorry. I’ve lived with slow disk startup for a long time and supposed it’s just down to my USB caddy. I see no difference between Nov2020 and current release.

1 Like

It was much better previous to the latest release, even on the beta - usally 3-5 secs on average.

Just bumping again as think this was lost on the mix. The HDD issue is very noticeable on media start up. Even when pausing/ unpausing, there is a noticeable delay in the system reacting. As mentioned, there was no issue on the beta.

That sounds different from disk spin-up. More like a slow LAN connection. Can you test LAN speeds?

Should have said. These are locally attached disks.

That is weird, then.

@sam_nazarko - could you advise, please?

I can’t think of anything that would cause such a delay.

Are you sure that the issue is indeed related to spin-up time and not the fact that our new kernel and video stack might be demanding a larger buffer?

Hmm, well, it also happens on pause/ unpause when surely the buffer is already full. As mentioned, this behaviour was not exhibited on 19.1 beta.

Drives curretly runnig via a (powered) hub, let me try directly to vero to see if any improvement.

Just tried plugged directly in, so drive awake I guess, and it took 10 secs to start a tv show. In hub, it’s approx. the same.
The logs not show anything?

How is the drive formatted?
How large are these files?

ext4.
Happens on a variety of file sizes, but that test I did was 1.25gb

Do you have another USB hard drive that you could compare with?

Hi,

Tried it with another powered drive plugged directly into the vero - about 10 secs again

Hello,

+1

Looks like I did not read the recent topics carefully.
Sorry I just created a new thread reporting the exact same issue with opening local video files being so slow. In my case even 15 to 25sec like all GUI is frozen, then it is ok.
Happening on any type of video, looks independant of size or type.

I do see 3 Errors in the log just before the video eventually starts, but unsure if related (error getting /home/osmc/.kodi/temp directory …)

I can’t say for sure since which update, but was 2-3sec and rolling on Leia.

My log

https://paste.osmc.tv/eyarudivub

See here. Solved my issue: Long pause before videos start to play - #20 by fzinken

Can you please post the output of ls -lah .kodi/temp/ and also df -h

After posting that two try to remove the kodi temp folder with rm -r .kodi/temp/*