HDR Autoswitch causing issues on my LG OLED65C8

With auto refresh rate off you get 1080P with HDR if your UI is set to 1080P.
I have an LG C8 and had all these issues as well but they all went away when I changed the CEC/ARC settings.
From my experience I think it’s a CEC/ARC issue.
I can even get it to work with a cheap 10Gbps HDMI too.

Here’s what I got if it helps at all:


1 Like

Dude, awesome! Thank you! This helped (tested several videos and OK!)

Settings->System->Input->Periphetals->CEC Adapter

  • Switch source to this device on startup Enabled
  • Devices to power on/off were disabled, changed to TV
  • Send “Inactive source” command on shutdown enabled
  • Put devices in standby mode when activating the screensaver enabled
  • wake devices when deactivating the screensaver enabled
1 Like

Indeed, with those CEC settings it’s working! Tested it with several 4k HDR Movies and Auto Refresh Rate ON, all of them played without problems in Resolution switching/lost Signal… Thanks!

1 Like

Tryed this, but it has no effect for me. Still going to no signal when playing the demo files mentioned in this thread.

Funny though. I have now tryed Haunting of Hill Hause 4k. Started out with no signal, pressed the back button on the vero remote. It returns to the menu but starts to play the file on the background or something. When I try to resume the video it goes back to no signal. So now I have a spooky episode playing and now way of stopping it :stuck_out_tongue:

I guess there are multiple issues then. It’s great that we have Sam.

Still though, the CEC settings you mentioned are doing something at least. It can now play on the background :stuck_out_tongue:

But the settings on itself a far from ideal. I dont want my TV shutting down when I watch some live tv not via the vero.

I’ll make a new thread with a number of improvements shortly; then we can check out the corner cases and get those solved.



I have now applied the hotfix and everything is working flawlessly again. Hoping for a permanent fix in the near future :slight_smile:

Do you mean you don’t get banding when playing a 4k60hz video?

For the record, on the August release, the GUI and everything else was in 8-bit unless you forced 10bit with either the ‘HDR auto’ mode or with echo 10bit > attr.

On the October release, everything is played in 10-bit. This has exposed issues with some screens. I suspect they didn’t have issues before because they were playing in 8 bits. People might not notice unless they are watching pale skies like the ones in The World in HDR and Revenant.

If anyone has evidence otherwise, we need to address that.

Sorry, ill be clear. Eveything is playing again. Received the vero recently and didn’t got it to play any UHD of HDR content. So i was happy that im at least playing something :yum: havent checked if it was 8 or 10 bits, but i expect 8. Ill check tomorrow to be sure

Thanks for the feedback. You shouldn’t have any issues with SDR content on any of the builds. The link with CEC is intriguing though…

I can verify mine is 10 bit.
No banding in the sky above the skateboarder in “The World In HDR”.

You guys can try and see if reverting the CEC settings back to default brings the problem back if you don’t care for the settings I use.
It’s possible that everything might still work after reverting.
Personally, I prefer these settings because I have my screensaver set to 5 minutes and when it kicks in it shuts my TV and soundbar off.
That way if I forget to shut it down it will do so on it’s own and I don’t have to worry about burn in.
I was an early adopter to plasma and I left my TV on over night once when I passed out and it had my desktop displayed the whole time.
It took weeks before the image retention went away (it did ultimately, but it freaked me out).
This method gives me some peace of mind.
Also it’s convenient to start watching the Vero too.
I just hit the home button on my Vero remote and that brings it out of screensaver mode which turns my TV and soundbar on as well.
By all means though, adjust the settings to what works best for your use case.
I’m glad it has helped some people so far!

1 Like

FYI… My LG C8 just updated from 4.10.6 to 4.10.15 firmware and everything still works the same.
Not sure what the new firmware changed, I’ve only found reports that it corrected some HDR dimming issues.

Hi @sam_nazarko! I had previously downgraded my OSMC by following the instructions here: Video improvement details - #7 by obstler42

Today I was not thinking and upgraded OMSC to the december release and again my 4K content cannot play. I thought no worries, I’ll just downgrade again but you have removed the code to downgrade. Can you please help me out?

There’s no ‘code’ to downgrade.
You’ll need to reinstall from osmc.tv/download.



Sam, that’s quite unfortunate as you previously supplied the code which was easy enough to enter to downgrade or hotfix as you called it. Now I have to try and find a USB-stick? Been years since I last used one. Is there any way it could be done via ssh instead?

You can also use a micro SD card to reinstall OSMC.
It’s better to get this solved for you properly, so you aren’t stuck on an old version of OSMC forever.


I agree Sam that solving the root cause would be better, but I cannot see any updates to this thread and the update to latest version put me back in to problems playing 4K HDR content. I did find a stick to reinstall but it’s a pain having to setup NFS shares etc.

What would your suggestion be going forward?