Remote control stopped working

Hey,
I have a Vero 4k with the original RF remote control.
I am not sure if it’s related to the latest update (I think not), but the remote control suddenly stopped working. I tried reconnecting the dongle, cold reset, hard reset, still not working.
Any way to debug this?

Thanks.

Hi,

Try replacing the battery.

Thanks Tom.

Thanks Tom.
I thought about it, but wasn’t expecting it to last only half a year.
If it was regular AA or AAA then i’d have checked it already, guess i’ll need to go and buy one anyway. In the meanwhile, any other suggestion to eliminate before I go to the store?

You need to change the remote battery every six to seven months on average. I find that I need to change the battery every nine months operating from a distance of 6m.

If you see a blue light when you press a button:

  • Remove the USB from Vero 4K / Pi
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K / Pi for 2 minutes. Turn it back on. The remote should now work.

If you don’t see a blue light, you need to replace the battery.
We considered moving to AA/AAA, but it would bulk the remote substantially.

You can buy genuine batteries for about 20p on Amazon (a fraction of the price of AA/AAA batteries)

Sam

1 Like

Thanks Sam,
Are we talking about the same remote? I don’t think my remote have any leds on it… :thinking:
Just to make sure, I am talking about the same remote as in the picture here - Vero - OSMC
Where is the led located? Haven’t noticed any led in the past few months

Yes — there’s an LED on the window of the remote that flashes blue when you press a button.

If it doesn’t flash, you likely need a new battery

Sam

1 Like

1 Like

For pairing, hold the remote very close to the dongle.

You can also pair them on a laptop in another room for even less HF interference.

The new remote (with volume +/i buttons) should be better then the old remote regarding battery life.

Shouldn’t need to be too close; but it helps.

Yes – you can get a couple of months extra battery on the latest model of remotes, introduced around January 2018.

Good to know! Is there a trading offer with the old one? :stuck_out_tongue:
Anyway, yea I just purchased a new battery and that solved it. I’ll mark this as solved.
Might be worth giving an option to purchase a spare battery when ordering the remote / vero4k, that way the user won’t get “stuck” after half a year or so… Just an offer :slight_smile:

Thanks!

Unfortunately this is difficult due to local laws and IATA shipping regulations. The order would have to be classified as dangerous goods and would be subject due additional customs clearance processes, even when the item is in free circulation (EU).

Hey,
Sorry for bumping this thread, but thought it’s better then opening a new one.

So I bought replacement batteries, and from the day of that post I replaced about 4 batteries. When the first two got empty so quickly I thought it might be the type of the batteries I bought, but then I switched to a different type (Philips), and still same thing. I find myself switching batteries like every month. =\

Is there anything to do?

If you re-pair the remote, this should resolve things for you. I get about 6 months on a single battery with regular usage.

Your remote is probably band hopping a lot at the moment

Sam

Hello, I know this thread is ancient, but currently I am facing the same issue, I bought my vero 4k+ second hand, and seller told me remote isnt working, but figured I’d give it a shot.
fresh battery, there is light in it.
I tried the above reconfig, by holding home and ok, the light then goes solid. It’s not flashing… after a while it (a minute/30-40 seconds maybe?) it flashes for a bit then turns off. I can press buttons and the light will turn on in the remote… but no response from the box

I have plugged the dongle into my pc, it does gets recognized. as a HID keyboard device, but thats it. Nothing happens… Any help would be greatly appreciated

1 Like

Is it recognised under OSMC?

I am new to the box completely. So how do I check that?

I don’t think the person who sold it, has factory restored it either. I did not get a setup screen as it’s explained in the quick start up. So perhaps somewhere in the settings it’s been disabled?

You can reinstall OSMC from the download page.

Yes, I will try that today. Hopefully it resolves the issue. Have ordered a new remote already in case the issue lies there. If a reinstall resolved it. … Hey! Nothing wrong with having a backup remote :slight_smile:

reinstall did not help, remote is still not responding/ working