Cheatsheets and Tutorials for users new to Linux based operating systems

Hopefully this will help some folks out

More cheatsheets:
http://www.cheat-sheets.org/#Linux

Tutorials:
http://www.pixelbeat.org/cmdline.html#monitor
http://linuxcommand.org/index.php
http://nixsrv.com/
http://rute.2038bug.com/index.html.gz
http://www.cyberciti.biz/tips/list-of-li...art-1.html

Apt-get tutorial for beginners.

18 Likes
Beginner! First time user of OSMC of RPi B
Added 2nd Raspberry Pi2 running OSMC - Cannot change Hostname, Permission Denied
MyOSMC update fails with Add-on error
Hyperion permissions file osmc
Trying to unstall firmware for ralink wifi.... are you root?
Root password
How to transfer files without samba / over the network
Pi Root Directory
Questions on my new Vero4k+
How To Update TVHeadend Server?
Newbie question: is OSMC open?
Can I install other Programs, and when how?
Sftp file transfer error Solved
Sad smiley on boot
Pi3 OSMC Transmission connect via nfs to nas
OSMC Update issue (no space on /)
Sad face loop URGENT
Sad face loop URGENT
Root access with SMB
How to adjust video cache via ssh
Custom Font?
ATV1 OSMC boots up with a Reset of sorts
How to create a skin based off of the default osmc skin
2 Pi installations and moving one media disk between them
Raspberry Pi3 lircd.conf File
[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC
[SOLVED] Wireless connection failing after router reset
Black screen on start up. fixed by reboot [Solved]
Recording to memory stick osmc tvheadend raspberry pi 3
Confusion over VPN client setup
I know nothing, but need help please. Looking for way to change directory
[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC
Stuttering issue with DVDLink (3.4.5) on Vero 4K
How to add a new folder to the Home directory?
3D Frame Packed output
Coming back to Kodi with Vero 4k+
Power settings with External Drive
/dev/vero-nand Full
Startup script
Apple TV 1 install from openelec
Profile Madness!
Linux thicko, need help getting addon cookie data via putty
OSMC does not recognize .zip
4k video playback issue after October update
Tethering and OpenVPN
64gb osmc install
SSH install PSmisc ... Please Help?
More Update Failures
OSMC /etc/-folder missing?
Some User Profiles not working after updating to Krypton
Help, sad face luup after update to v17
Blackout booting OSMC with NOOBS
Hamachi on OSMC
Man command not found?
Home folder not showing up after clean install!
The best way to rename a file?
Can we now do auto updates?
How to remove hyperion symbolic link at /etc/init.d

I would like to add this free source I’m currently using:

Linux Journey - https://linuxjourney.com
It’s a lesson based tutorial with exercises presented in a very friendly way.

2 Likes

Not a Cheatsheet but with detailed explanation about the most important Commands - however for German-speaking Readers: Linux-Anwenderhandbuch:wink:
It also contains a brief History of UNIX/ Linux in the first Chapter.:slightly_smiling_face:

1 Like

Goodnight!!
Can someone tell me how to reset the data? I’ve put so much shit in it that I’d like to start from scratch again. Without losing the My Oscm, of course.
thanks!!

This will return you to Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

1 Like

Hi. Ask me for a password to access. which?
THX!

it already. osmc and osmc. Thank you very much, I already have it clean.